removed merge fluff
[sahlberg/ctdb.git] / packaging / RPM / ctdb.spec
1 %define initdir %{_sysconfdir}/init.d
2
3 Summary: Clustered TDB
4 Vendor: Samba Team
5 Packager: Samba Team <samba@samba.org>
6 Name: ctdb
7 Version: 1.0.80
8 Release: 1
9 Epoch: 0
10 License: GNU GPL version 3
11 Group: System Environment/Daemons
12 URL: http://ctdb.samba.org/
13
14 Source: ctdb-%{version}.tar.gz
15
16 Prereq: /sbin/chkconfig /bin/mktemp /usr/bin/killall
17 Prereq: fileutils sed /etc/init.d
18
19 Provides: ctdb = %{version}
20
21 Prefix: /usr
22 BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24 %description
25 ctdb is the clustered database used by samba
26
27
28 #######################################################################
29
30 %prep
31 %setup -q
32 # setup the init script and sysconfig file
33 %setup -T -D -n ctdb-%{version} -q
34
35 %build
36
37 ## check for ccache
38 if ccache -h >/dev/null 2>&1 ; then
39         CC="ccache gcc"
40 else
41         CC="gcc"
42 fi
43
44 export CC
45
46 ## always run autogen.sh
47 ./autogen.sh
48
49 CFLAGS="$RPM_OPT_FLAGS $EXTRA -O0 -D_GNU_SOURCE -DCTDB_VERS=\"%{version}-%{release}\"" ./configure \
50         --prefix=%{_prefix} \
51         --sysconfdir=%{_sysconfdir} \
52         --mandir=%{_mandir} \
53         --localstatedir="/var"
54
55 make docdir=%{_docdir} showflags
56 make docdir=%{_docdir}
57
58 %install
59 # Clean up in case there is trash left from a previous build
60 rm -rf $RPM_BUILD_ROOT
61
62 # Create the target build directory hierarchy
63 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
64 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
65
66 make DESTDIR=$RPM_BUILD_ROOT docdir=%{_docdir} install
67
68 install -m644 config/ctdb.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ctdb
69 install -m755 config/ctdb.init $RPM_BUILD_ROOT%{initdir}/ctdb
70
71 # Remove "*.old" files
72 find $RPM_BUILD_ROOT -name "*.old" -exec rm -f {} \;
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 [ -x /sbin/chkconfig ] && /sbin/chkconfig --add ctdb
79
80 %preun
81 if [ $1 = 0 ] ; then
82     [ -x /sbin/chkconfig ] && /sbin/chkconfig --del ctdb
83 fi
84 exit 0
85
86 %postun
87 if [ "$1" -ge "1" ]; then
88         %{initdir}/ctdb restart >/dev/null 2>&1 || true
89 fi      
90
91
92 #######################################################################
93 ## Files section                                                     ##
94 #######################################################################
95
96 %files
97 %defattr(-,root,root)
98
99 %config(noreplace) %{_sysconfdir}/sysconfig/ctdb
100 %config(noreplace) %{_sysconfdir}/ctdb/notify.sh
101 %config(noreplace) %{_sysconfdir}/ctdb/functions
102 %attr(755,root,root) %{initdir}/ctdb
103
104 %{_docdir}/ctdb/README.eventscripts
105 %{_docdir}/ctdb/recovery-process.txt
106 %{_sysconfdir}/ctdb/events.d/00.ctdb
107 %{_sysconfdir}/ctdb/events.d/10.interface
108 %{_sysconfdir}/ctdb/events.d/11.natgw
109 %{_sysconfdir}/ctdb/events.d/20.multipathd
110 %{_sysconfdir}/ctdb/events.d/40.vsftpd
111 %{_sysconfdir}/ctdb/events.d/41.httpd
112 %{_sysconfdir}/ctdb/events.d/50.samba
113 %{_sysconfdir}/ctdb/events.d/60.nfs
114 %{_sysconfdir}/ctdb/events.d/61.nfstickle
115 %{_sysconfdir}/ctdb/events.d/70.iscsi
116 %{_sysconfdir}/ctdb/events.d/90.ipmux
117 %{_sysconfdir}/ctdb/events.d/91.lvs
118 %{_sysconfdir}/ctdb/events.d/99.routing
119 %{_sysconfdir}/ctdb/statd-callout
120 %{_sbindir}/ctdbd
121 %{_bindir}/ctdb
122 %{_bindir}/smnotify
123 %{_bindir}/ctdb_ipmux
124 %{_bindir}/ctdb_diagnostics
125 %{_bindir}/onnode
126 %{_mandir}/man1/ctdb.1.gz
127 %{_mandir}/man1/ctdbd.1.gz
128 %{_mandir}/man1/onnode.1.gz
129 %{_includedir}/ctdb.h
130 %{_includedir}/ctdb_private.h
131 %{_libdir}/pkgconfig/ctdb.pc
132
133 %changelog
134 * Tue May 5 2009 : Version 1.0.69-6
135  - Try to add back the routes in 99.routing both for the takeip and also the
136    releaseip event since during releaseip) too many addresses may have been
137    deleted, causing routes to be lost.
138    See 10.interfaces for the workaround for "ip addr del" deleting too
139    many addresses.
140 * Fri May 1 2009 : Version 1.0.80
141  - change init shutdown level to 01 for ctdb so it stops before any of the other services
142  - if we can not pull a database from a remote node during recovery, mark that node as a culprit so it becomes banned
143  - increase the loglevel when we volunteer to drop all ip addresses after beeing in recovery mode for too long. Make this timeout tuneable with "RecoveryDropAllIPs" and have it default to 60 seconds
144  - Add a new flag TDB_NO_NESTING to the tdb layer to prevent nested transactions which ctdb does not use and does not expect. Have ctdb set this flag to prevent nested transactions from occuring.
145  - dont unconditionally kill off ctdb and restrat it on "service ctdb start". Fail "service ctdb start" with an error if ctdb is already running.
146  - Add a new tunable "VerifyRecoveryLock" that can be set to 0 to prevent the main ctdb daemon to verify that the recovery master has locked the reclock file correctly before allowing it to set the recovery mode to active.
147  - fix a cosmetic bug with ctdb statistics where certain counters could become negative.
148 * Fri May 1 2009 : Version 1.0.69-5
149  - Add a new variable VerifyRecoveryLock. When set to 0 this will skip
150    the test inside the main where it verifies that the recovery masted does
151    hold the lock to the reclock file while performing a recovery.
152  - Change the timeout for waiting for a reclock child process to terminate to
153    15 seconds and increase the logging of this potentially fatal condition.
154 * Sun Apr 26 2009 : Version 1.0.69_4
155  - Add TDB_NO_NESTING to the tdb layer to prevent transaction nesting.
156  - Make sure that when we start a recovery transaction that this is not a
157    nested transaction.
158  - Add a tuneable RecoveryDropAllIPs that specifies after how long being in
159    recovery mode a node will elect to drop all its public addresses.
160 * Fri Apr 24 2009 : Version 1.0.69_3
161  - Make sure that if during recovery a node is stuck and does not reply to
162    pull_db requests that we eventually ban this node from the recovery master.
163 * Thu Apr 23 2009 : Version 1.0.69_2
164  - In the recovery daemon we dont need to check the nodemap status
165    of banned nodes.
166 * Wed Apr 8 2009 : Version 1.0.79
167  - From Mathieu Parent: add a ctdb pkgconfig file
168  - Fix bug 6250
169  - add a funciton remove_ip to safely remove an ip from an interface, taking care to workaround an issue with linux alias interfaces.
170  - Update the natgw eventscript to use the safe remove_ip() function
171  - fix a bug in the eventscript child process that would cause the socket to be removed.
172  - dont verify nodemap on banned nodes during cluster monitoring
173  - Update the dodgy SeqnumInterval to have ms resolution
174 * Tue Mar 31 2009 : Version 1.0.78
175  - Add a notify mechanism so we can send snmptraps/email to external management systems when the node becomes unhealthy
176  - include 11.natgw eventscript in thew install so that the NATGW feature works
177 * Tue Mar 31 2009 : Version 1.0.77
178  - Update the 99.routing eventscript to also try to add the routes (back) during a releaseip event. Similar to the reasons why we must add addresses back during releaseip in 10.interfaces
179 * Wed Mar 24 2009 : Version 1.0.76
180  - Add a debugging command "xpnn" which can print the pnn of the node even when ctdbd is not running.
181  - Redo the NATGW implementation to allow multiple disjoing NATGW groups in the same cluster.
182 * Tue Mar 24 2009 : Version 1.0.75
183  - Various updates to LVS
184  - Fix a bug in the killtcp control where we did not set the port correctly
185  - add a new "ctdb scriptstatus" command that shows the status of the eventrscripts.
186 * Mon Mar 16 2009 : Version 1.0.74
187  - Fixes to AIX from C Cowan.
188  - Fixes to ctdb_diagnostics so we collect correct GPFS data
189  - Fixes to the net conf list command in ctdb_diagnostics
190  - Check the static-routes file IFF it exists in ctdb_diagnostics
191 * Wed Mar 4 2009 : Version 1.0.73
192  - Add possibility to disable the check of shares for NFS and Samba
193  - From Sumit Bose, fix dependencies so make -j works
194 * Wed Feb 18 2009 : Version 1.0.72
195  - Updates to test scripts by martin s
196  - Adding a COPYING file
197  - Use netstat to check for services and ports and fallback to netcat
198    only if netstat is unavailable.
199 * Mon Feb 2 2009 : Version 1.0.71
200  - Additional ipv6 fixes from Michael Adams
201 * Fri Jan 16 2009 : Version 1.0.70
202  - IPv6 support is completed. this is backward compatible with ipv4-only
203    systems. To use IPv6 with samba and ctdb you need current GIT of samba 3.3
204    or michael adams samba-ctdeb branch.
205  - Many enhancements to the build system and scripts to make it more SUSE
206    friendly by Michael Adams.
207  - Change of how the naming of the package is structured. We are now
208    using "1.0.70" as a release and "-1" as the revision instead of as
209    previously using "1.0" as release and ".70" as the revision.
210    By Michael Adams.
211 * Wed Feb 5 2009 : Version 1.0.69_1
212  - Dont check the result of the modflags control, to allow compatibility
213    with earlier versions of ctdb
214 * Thu Dec 18 2008 : Version 1.0.69
215  - Various fixes to scripts by M Adam
216  - Dont call ctdb_fatal() when the transport is down during shutdown
217 * Fri Dec 12 2008 : Version 1.0.68
218  - Fixes for monitoring of interfaces status from Michael Adam.
219  - Use -q instead of >/dev/null for grep to enhance readability of the
220    scripts from Michael Adam.
221  - Update to the "ctdb recover" command. This command now block until the
222    has completed. This makes it much easier to use in scripts and avoids
223    the common workaround :
224       ctdb recover
225       ... loop while waiting for recovery completes ...
226       continue ...
227  - Add a CTDB_TIMEOUT variable. If set, this variable provides an automatic
228    timeout for "ctdb <command>", similar to using -T <timeout>
229  - Set a unique errorcode for "ctdb <command>" when it terminates due to a 
230    timeout so that scripts can distinguish between a hung command and what was
231    just a failure.
232  - Update "ctdb ban/unban" so that if the cluster is in recovery these commands
233    blocks and waits until after recovery is complete before the perform the
234    ban/unban operation. This is necessary since the recovery process can cause
235    nodes to become automatically unbanned.
236  - Update "ctdb ban/unban" to block until the recovery that will follow shortly
237    after this command has completed.
238    This makes it much easier to use in scripts and avoids the common
239    workaround :
240       ctdb ban/unban
241       ... loop while waiting for recovery completes ...
242       continue ...
243  - Bugfix for the new flags handling in 1.0.67. Abort and restart monitoring
244    if we failed to get proper nodemaps from a remote node instead of
245    dereferencing a null pointer.
246  - If ctdbd was explicitely started with the '--socket' argument, make
247    ctdbd automatically set CTDB_SOCKET to the specified argument.
248    This ensures that eventscripts spawned by the ctdb daemon will default to
249    using the same socket and talk to the correct daemon.
250    This primarily affects running multiple daemons on the same host and where 
251    you want each instance of ctdb daemons have their eventscripts talk to the
252    "correct" daemon.
253  - Update "ctdb ping" to return an error code if the ping fail so that it
254    can be used in scripts.
255  - Update to how to synchronize management of node flags across the cluster.
256 * Thu Dec 3 2008 : Version 1.0.67
257  - Add a document describing the recovery process.
258  - Fix a bug in "ctdb setdebug" where it would refuse to set a negative
259    debug level.
260  - Print the list of literals for debug names if an invalid one was given
261    to "ctdb setdebug"
262  - Redesign how "ctdb reloadnodes" works and reduce the amont of tcp teardowns
263    used during this event.
264  - Make it possible to delete a public ip from all nodes at once using
265    "ctdb delip -n all"
266 * Mon Nov 24 2008 : Version 1.0.66
267  - Allow to change the recmaster even when we are not frozen.
268  - Remove two redundant SAMBA_CHECK variables from the sysconf example
269  - After a node failure it can take very long before some lock operations
270    ctdb needs to perform are allowed/works with gpfs again. Workaround this
271    by treating a hang/timeout as success.
272  - Dont override CTDB_BASE is fet in the shell already
273  - Always send keepalive packets regardless of whether the link is idle or not.
274  - Rewrite the disable/enable flag update logic to prevent a race between 
275    "ctdb disable/enable" and the recovery daemon when updating the flags to 
276    all nodes.
277 * Thu Nov 13 2008 : Version 1.0.65
278  - Update the sysconfig example: The default debug level is 2 (NOTICE) and not
279    0 (ERROR)
280  - Add support for a CTDB_SOCKET environment variable for the ctdb command
281    line tool. If set, this overrides the default socket the ctdb tool will
282    use.
283  - Add logging of high latency operations.
284 * Mon Oct 22 2008 : Version 1.0.64
285  - Add a context and a timed event so that once we have been in recovery for
286    too long we drop all public addresses.
287 * Mon Oct 20 2008 : Version 1.0.63
288  - Remove logging of "periodic cleanup ..." in 50.samba
289  - When we reload a nodes file, we must detect this and reload the file also
290    in the recovery daemon before we try to dereference somethoung beyond the end
291    of the nodes array.
292 * Thu Oct 16 2008 : Version 1.0.62
293  - Allow multiple eventscritps using the same prefix number.
294    It is undefined which order scripts with the same prefix will execute in.
295 * Wed Oct 15 2008 : Version 1.0.61
296  - Use "route add -net" instead of "ip route add" when adding routes in 99.routing
297  - lower the loglevel os several debug statements
298  - check the status returned from ctdb_ctrl_get_tickles() before we try to print them out to the screen.
299  - install a new eventscript 20.multipathd whoich can be used to monitor that multipath devices are healthy
300 * Wed Oct 15 2008 : Version 1.0.60
301  - Verify that nodes we try to ban/unban are reachable and print an error othervise.
302  - Update the client and server sides of TAKEIP/RELEASEIP/GETPUBLICIPS and GETNODEMAP to fall back to the old style ipv4-only controls if the new ipv4/ipv6 controls fail. This allows an ipv4/v6 enabled ctdb daemon to interoperate with earlier ipv4-only versions of the daemons.
303  - From Mathieu Parent : log debian systems log the package versions in ctdb diagnostics
304  - From Mathieu Parent : specify logdir location for debian (this patch was later reversed)
305  - From Michael Adams : allow # comments in nodes/public_addresses files
306 * Tue Oct 7 2008 : Version 1.0.59
307  - Updated "reloadnodes" logic. Instead of bouncing the entire tcp layer it is sufficient to just close and reopen all outgoing tcp connections.
308  - New eventscript 99.routing which can be used to re-attach routes to public interfaces after a takeip event. (routes may be deleted by the kernel when we release an ip)
309  - IDR tree fix from Jim Houston
310  - Better handling of critical events if the local clock is suddenly changed forward by a lot.
311  - Fix three slow memory leaks in the recovery daemon
312  - New ctdb command : ctdb recmaster   which prints the pnn of the recmaster
313  - Onnode enhancements from Martin S : "healthy" and "connected" are now possible nodespecifiers
314  - From Martin S : doc fixes
315  - lowering some debug levels for some nonvital informational messages
316  - Make the daemon daemon monitoring stronger and allow ctdbd to detect a hung
317    recovery daemon.
318  - From C Cowan : patches to compile ipv6 under AIX
319  - zero out some structs to keep valgrind happy
320 * Wed Aug 27 2008 : Version 1.0.58
321  - revert the name change tcp_tcp_client back to tcp_control_tcp so
322    samba can build.
323  - Updates to the init script from Abhijith Das <adas@redhat.com>
324 * Mon Aug 25 2008 : Version 1.0.57
325  - initial support for IPv6
326 * Mon Aug 11 2008 : Version 1.0.56
327  - fix a memory leak in the recovery daemon.
328 * Mon Aug 11 2008 : Version 1.0.55
329  - Fix the releaseip message we seond to samba.
330 * Fri Aug 8 2008 : Version 1.0.54
331  - fix a looping error in the transaction code
332  - provide a more detailed error code for persistent store errors
333    so clients can make more intelligent choices on how to try to recover
334 * Thu Aug 7 2008 : Version 1.0.53
335  - Remove the reclock.pnn file   it can cause gpfs to fail to umount
336  - New transaction code
337 * Mon Aug 4 2008 : Version 1.0.52
338  - Send an explicit gratious arp when starting sending the tcp tickles.
339  - When doing failover, issue a killtcp to non-NFS/non-CIFS clients
340    so that they fail quickly. NFS and CIFS already fail and recover 
341    quickly.
342  - Update the test scripts to handle CTRL-C to kill off the test.
343 * Mon Jul 28 2008 : Version 1.0.51
344  - Strip off the vlan tag from bond devices before we check in /proc
345    if the interface is up or not.
346  - Use testparm in the background in the scripts to allow probing
347    that the shares do exist.
348  - Fix a bug in the logging code to handle multiline entries better
349  - Rename private elements from private to private_data
350 * Fri Jul 18 2008 : Version 1.0.50
351  - Dont assume that just because we can establish a TCP connection
352    that we are actually talking to a functioning ctdb daemon.
353    So dont mark the node as CONNECTED just because the tcp handshake
354    was successful.
355  - Dont try to set the recmaster to ourself during elections for those
356    cases we know this will fail. To remove some annoying benign but scary
357    looking entries from the log.
358  - Bugfix for eventsystem for signal handling that could cause a node to
359    hang.
360 * Thu Jul 17 2008 : Version 1.0.49
361  - Update the safe persistent update fix to work with unpatched samba
362    servers.
363 * Thu Jul 17 2008 : Version 1.0.48
364  - Update the spec file.
365  - Do not start new user-triggered eventscripts if we are already
366    inside recovery mode.
367  - Add two new controls to start/cancel a persistent update.
368    A client such as samba can use these to tell ctdbd that it will soon
369    be writing directly to the persistent database tdb file. So if
370    samba is -9ed before it has eitehr done the persistent_store or
371    canceled the operation, ctdb knows that the persistent databases
372    'may' be out of sync and therefore a full blown recovery is called for.
373  - Add two new options :
374    CTDB_SAMBA_SKIP_CONF_CHECK and CTDB_SAMBA_CHECK_PORTS that can be used
375    to override what checks to do when monitoring samba health.
376    We can no longer use the smbstatus, net or testparm commands to check
377    if samba or its config is healthy since these commands may block
378    indefinitely and thus can not be used in scripts.
379 * Fri Jul 11 2008 : Version 1.0.47
380  - Fix a double free bug where if a user striggered (ctdb eventscript)
381    hung and while the timeout handler was being processed a new user
382    triggered eventscript was started we would free state twice.
383  - Rewrite of onnode and associated documentation.
384 * Thu Jul 10 2008 : Version 1.0.46
385  - Document both the LVS:cingle-ip-address and the REMOTE-NODE:wan-accelerator
386    capabilities.
387  - Add commands "ctdb pnn", "ctdb lvs", "ctdb lvsmaster".
388  - LVS improvements. LVS is the single-ip-address mode for a ctdb cluster.
389  - Fixes to supress rpmlint warnings
390  - AXI compile fixes.
391  - Change \s to [[:space:]] in some scripts. Not all RHEL5 packages come
392    with a egrep that handles \s   even same version but different arch.
393  - Revert the change to NFS restart. CTDB should NOT attempt to restart
394    failed services.
395  - Rewrite of the waitpid() patch to use the eventsystem for handling
396    signals.
397 * Tue Jul 8 2008 : Version 1.0.45
398  - Try to restart the nfs service if it has failed to respond 3 times in a row.
399  - waitpid() can block if the child does not respond promptly to SIGTERM.
400    ignore all SIGCHILD signals by setting SIGCHLD to SIG_DEF.
401    get rid of all calls to waitpid().
402  - make handling of eventscripts hanging more liberal.
403    only consider the script to have failed and making the node unhealthy
404    IF the eventscript terminated wiht an error
405    OR the eventscript hung 5 or more times in a row
406 * Mon Jul 7 2008 : Version 1.0.44
407  - Add a CTDB_VALGRIND option to /etc/sysconfig/ctdb to make it start
408    ctdb under valgrind. Logs go to /var/log/ctdb_valgrind.PID
409  - Add a hack to show the control opcode that caused uninitialized data
410    in the valgrind output by encoding the opcode as the line number.
411  - Initialize structures and allocated memory in various places in
412    ctdb to make it valgrind-clean and remove all valgrind errors/warnings.
413  - If/when we destroy a lockwait child, also make sure we cancel any pending transactions
414  - If a transaction_commit fails, delete/cancel any pending transactions and
415    return an error instead of calling ctdb_fatal()
416  - When running ctdb under valgrind, make sure we run it with --nosetsched and also
417    ensure that we do not use mem-mapped i/o when accessing the tdb's.
418  - zero out ctdb->freeze_handle when we free/destroy a freeze-child.
419    This prevent a heap corruption/ctdb crash bug that could trigger
420    if the freeze child times out.
421  - we dont need to explicitely thaw the databases from the recovery daemon
422    since this is done implicitely when we restore the recovery mode back to normal.
423  - track when we start and stop a recovery. Add the 'time it took to complete the
424    recovery' to the 'ctdb uptime' output.
425    Ensure by tracking the start/stop recovery timestamps that we do not
426    check that the ip allocation is consistend from inside the recovery daemon
427    while a different node (recovery master) is performing a recovery.
428    This prevent a race that could cause a full recovery to trigger if the
429    'ctdb disable/enable' commands took very long.
430  - The freeze child indicates to the master daemon that all databases are locked
431    by writing data to the pipe shared with the master daemon.
432    This write sometimes fail and thus the master daemon never notices that the databases
433    are locked cvausing long timeouts and extra recoveries.
434    Check that the write is successful and try the write again if it failed.
435  - In each node, verify that the recmaster have the right node flags for us
436    and force a push of our flags to the recmaster if wrong.
437 * Tue Jul 1 2008 : Version 1.0.43
438  - Updates and bugfixes to the specfile to keep rpmlint happy
439  - Force a global flags update after each recovery event.
440  - Verify that the recmaster agrees with our node flags and update the
441    recmaster othervise.
442  - When writing back to the parent from a freeze-child across the pipe,
443    loop over the write in case the write failed with an error  othervise
444    the parent will never be notified tha the child has completed the operation.
445  - Automatically thaw all databases when recmaster marks us as being in normal
446    mode instead of recovery mode.
447 * Fri Jun 13 2008 : Version 1.0.42
448  - When event scripts have hung/timedout more than EventScriptBanCount times
449    in a row the node will ban itself.
450  - Many updates to persistent write tests and the test scripts.
451 * Wed May 28 2008 : Version 1.0.41
452  - Reactivate the safe writes to persistent databases and solve the
453    locking issues. Locking issues are solved the only possible way,
454    by using a child process to do the writes.  Expensive and slow but... . 
455 * Tue May 27 2008 : Version 1.0.40
456  - Read the samba sysconfig file from the 50.samba eventscript
457  - Fix some emmory hierarchical bugs in the persistent write handling
458 * Thu May 22 2008 : Version 1.0.39
459  - Moved a CTDB_MANAGES_NFS, CTDB_MANAGES_ISCSI and CTDB_MANAGES_CSFTPD
460    into /etc/sysconfig/ctdb
461  - Lowered some debug messages to not fill the logfile with entries
462    that normally occur in the default configuration.
463 * Fri May 16 2008 : Version 1.0.38
464  - Add machine readable output support to "ctdb getmonmode"
465  - Lots of tweaks and enhancements if the event scripts are "slow"
466  - Merge from tridge: an attempt to break the chicken-and-egg deadlock that
467    net conf introduces if used from an eventscript.
468  - Enhance tickles so we can tickle an ipv6 connection.
469  - Start adding ipv6 support : create a new container to replace sockaddr_in.
470  - Add a checksum routine for ipv6/tcp
471  - When starting up ctdb, let the init script do a tdbdump on all
472    persistent databases and verify that they are good (i.e. not corrupted).
473  - Try to use "safe transactions" when writing to a persistent database
474    that was opened with the TDB_NOSYNC flag. If we can get the transaction
475    thats great, if we cant  we have to write anyway since we cant block here.
476 * Mon May 12 2008 : Version 1.0.37
477  - When we shutdown ctdb we close the transport down before we run the 
478    "shutdown" eventscripts. If ctdb decides to send a packet to a remote node
479    after we have shutdown the transport but before we have shutdown ctdbd
480    itself this could lead to a SEGV instead of a clean shutdown. Fix.
481  - When using the "exportfs" command to extract which NFS export directories
482    to monitor,  exportfs violates the "principle of least surprise" and
483    sometimes report a single export line as two lines of text output
484    causing the monitoring to fail.
485 * Fri May 9 2008 : Version 1.0.36
486  - fix a memory corruption bug that could cause the recovery daemon to crash.
487  - fix a bug with distributing public ip addresses during recovery.
488    If the node that is the recovery master did NOT use public addresses,
489    then it assumed that no other node in the cluster used them either and
490    thus skipped the entire step of reallocating public addresses.
491 * Wed May 7 2008 : Version 1.0.35
492  - During recovery, when we define the new set of lmasters (vnnmap)
493    only consider those nodes that have the can-be-lmaster capability
494    when we create the vnnmap. unless there are no nodes available which
495    supports this capability in which case we allow the recmaster to
496    become lmaster capable (temporarily).
497  - Extend the async framework so that we can use paralell async calls
498    to controls that return data.
499  - If we do not have the "can be recmaster" capability, make sure we will
500    lose any recmaster elections, unless there are no nodes available that
501    have the capability, in which case we "take/win" the election anyway.
502  - Close and reopen the reclock pnn file at regular intervals.
503    Make it a non-fatal event if we occasionally fail to open/read/write
504    to this file.
505  - Monitor that the recovery daemon is still running from the main ctdb
506    daemon and shutdown the main daemon when recovery daemon has terminated.
507  - Add a "ctdb getcapabilities" command to read the capabilities off a node.
508  - Define two new capabilities : can be recmaster and can be lmaster
509    and default both capabilities to YES.
510  - Log denied tcp connection attempts with DEBUG_ERR and not DEBUG_WARNING
511 * Thu Apr 24 2008 : Version 1.0.34
512  - When deleting a public ip from a node, try to migrate the ip to a different
513    node first.
514  - Change catdb to produce output similar to tdbdump
515  - When adding a new public ip address, if this ip does not exist yet in
516    the cluster, then grab the ip on the local node and activate it.
517  - When a node disagrees with the recmaster on WHO is the recmaster, then
518    mark that node as a recovery culprit so it will eventually become
519    banned.
520  - Make ctdb eventscript support the -n all argument.
521 * Thu Apr 10 2008 : Version 1.0.33
522  - Add facilities to include site local adaptations to the eventscript
523    by /etc/ctdb/rc.local which will be read by all eventscripts.
524  - Add a "ctdb version" command.
525  - Secure the domain socket with proper permissions from Chris Cowan
526  - Bugfixes for AIX from Chris Cowan
527 * Wed Apr 02 2008 : Version 1.0.32
528  - Add a control to have a node execute the eventscripts with arbitrary
529    command line arguments.
530  - Add a control "rddumpmemory" that will dump the talloc memory allocations
531    for the recovery daemon.
532  - Decorate the talloc memdump to produce better and easier memory leak
533    tracking. 
534  - Update the RHEL5 iscsi tgtd scripts to allow one iscsi target for each
535    public address.
536  - Add two new controls "addip/delip" that can be used to add/remove public
537    addresses to a node at runtime. After using these controls a "ctdb recover"
538    ir required to make the changes take.
539  - Fix a couple of slow memory leaks.
540 * Tue Mar 25 2008 : Version 1.0.31
541  - Add back controls to disable/enable monitoring on a node.
542  - Fix a memory leak where we used to attach CALL data to the ctdb structure
543    when performing a local call. Memory which would be lost if the call was
544    aborted.
545  - Reduce the loglevel for the log output when someone connects to a non
546    public ip address for samba.
547  - Redo and optimize the vacuuming process to send only one control to each
548    other node containing all records to be vacuumed instead of one
549    control per node per record.
550 * Tue Mar 04 2008 : Version 1.0.30
551  - Update documentation cor new commands and tuneables
552  - Add machinereadable output to the ip,uptime and getdebug commands
553  - Add a moveip command to manually failover/failback public ips
554  - Add NoIPFallback tuneable that prevents ip address failback
555  - Use file locking inside the CFS as alternative to verify when other nodes
556    Are connected/disconnected to be able to recover from split network
557  - Add DisableWhenUnhealthy tunable
558  - Add CTDB_START_AS_DISABLED sysconfig param
559  - Add --start-as-disabled flag to ctdb
560  - Add ability to monitor for OOM condition
561 * Thu Feb 21 2008 : Version 1.0.29
562  - Add a new command to make expansion of an existing cluster easier
563  - Fix bug with references to freed objects in the ctdb structure
564  - Propagate debuglevel changes to the recovery daemon
565  - Merge patches to event scripts from Mathieu Parent :
566  - MP: Simulate "service" on systems which do not provide this tool
567  - MP: Set correct permissions for events.d/README
568  - Add nice helper functions to start/stop nfs from the event scripts
569 * Fri Feb 08 2008 : Version 1.0.28
570  - Fix a problem where we tried to use ethtool on non-ethernet interfaces
571  - Warn if the ipvsadm packege is missing when LVS is used
572  - Dont use absolute pathnames in some of the event scripts
573  - Fix for persistent tdbs growing inifinitely.
574 * Wed Feb 06 2008 : Version 1.0.27
575  - Add eventscript for iscsi
576 * Thu Jan 31 2008 : Version 1.0.26
577  - Fix crashbug in tdb transaction code
578 * Tue Jan 29 2008 : Version 1.0.25
579  - added async recovery code
580  - make event scripts more portable
581  - fixed ctdb dumpmemory
582  - more efficient tdb allocation code
583  - improved machine readable ctdb status output
584  - added ctdb uptime
585 * Wed Jan 16 2008 : Version 1.0.24
586  - added syslog support
587  - documentation updates
588 * Wed Jan 16 2008 : Version 1.0.23
589  - fixed a memory leak in the recoveryd
590  - fixed a corruption bug in the new transaction code
591  - fixed a case where an packet for a disconnected client could be processed
592  - added http event script
593  - updated documentation
594 * Thu Jan 10 2008 : Version 1.0.22
595  - auto-run vacuum and repack ops
596 * Wed Jan 09 2008 : Version 1.0.21
597  - added ctdb vacuum and ctdb repack code
598 * Sun Jan 06 2008 : Version 1.0.20
599  - new transaction based recovery code
600 * Sat Jan 05 2008 : Version 1.0.19
601  - fixed non-master bug
602  - big speedup in recovery for large databases
603  - lots of changes to improve tdb and ctdb for high churn databases
604 * Thu Dec 27 2007 : Version 1.0.18
605  - fixed crash bug in monitor_handler
606 * Tue Dec 04 2007 : Version 1.0.17
607  - fixed bugs related to ban/unban of nodes
608  - fixed a race condition that could lead to monitoring being permanently disabled,
609    which would lead to long recovery times
610  - make deterministic IPs the default
611  - fixed a bug related to continuous recovery 
612  - added a debugging option --node-ip