new version 1.0.79
[sahlberg/ctdb.git] / packaging / RPM / ctdb.spec
1 %define initdir %{_sysconfdir}/init.d
2
3 Summary: Clustered TDB
4 Vendor: Samba Team
5 Packager: Samba Team <samba@samba.org>
6 Name: ctdb
7 Version: 1.0.79
8 Release: 1
9 Epoch: 0
10 License: GNU GPL version 3
11 Group: System Environment/Daemons
12 URL: http://ctdb.samba.org/
13
14 Source: ctdb-%{version}.tar.gz
15
16 Prereq: /sbin/chkconfig /bin/mktemp /usr/bin/killall
17 Prereq: fileutils sed /etc/init.d
18
19 Provides: ctdb = %{version}
20
21 Prefix: /usr
22 BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24 %description
25 ctdb is the clustered database used by samba
26
27
28 #######################################################################
29
30 %prep
31 %setup -q
32 # setup the init script and sysconfig file
33 %setup -T -D -n ctdb-%{version} -q
34
35 %build
36
37 ## check for ccache
38 if ccache -h >/dev/null 2>&1 ; then
39         CC="ccache gcc"
40 else
41         CC="gcc"
42 fi
43
44 export CC
45
46 ## always run autogen.sh
47 ./autogen.sh
48
49 CFLAGS="$RPM_OPT_FLAGS $EXTRA -O0 -D_GNU_SOURCE -DCTDB_VERS=\"%{version}-%{release}\"" ./configure \
50         --prefix=%{_prefix} \
51         --sysconfdir=%{_sysconfdir} \
52         --mandir=%{_mandir} \
53         --localstatedir="/var"
54
55 make docdir=%{_docdir} showflags
56 make docdir=%{_docdir}
57
58 %install
59 # Clean up in case there is trash left from a previous build
60 rm -rf $RPM_BUILD_ROOT
61
62 # Create the target build directory hierarchy
63 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
64 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
65
66 make DESTDIR=$RPM_BUILD_ROOT docdir=%{_docdir} install
67
68 install -m644 config/ctdb.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ctdb
69 install -m755 config/ctdb.init $RPM_BUILD_ROOT%{initdir}/ctdb
70
71 # Remove "*.old" files
72 find $RPM_BUILD_ROOT -name "*.old" -exec rm -f {} \;
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 [ -x /sbin/chkconfig ] && /sbin/chkconfig --add ctdb
79
80 %preun
81 if [ $1 = 0 ] ; then
82     [ -x /sbin/chkconfig ] && /sbin/chkconfig --del ctdb
83 fi
84 exit 0
85
86 %postun
87 if [ "$1" -ge "1" ]; then
88         %{initdir}/ctdb restart >/dev/null 2>&1 || true
89 fi      
90
91
92 #######################################################################
93 ## Files section                                                     ##
94 #######################################################################
95
96 %files
97 %defattr(-,root,root)
98
99 %config(noreplace) %{_sysconfdir}/sysconfig/ctdb
100 %config(noreplace) %{_sysconfdir}/ctdb/notify.sh
101 %config(noreplace) %{_sysconfdir}/ctdb/functions
102 %attr(755,root,root) %{initdir}/ctdb
103
104 %{_docdir}/ctdb/README.eventscripts
105 %{_docdir}/ctdb/recovery-process.txt
106 %{_sysconfdir}/ctdb/events.d/00.ctdb
107 %{_sysconfdir}/ctdb/events.d/10.interface
108 %{_sysconfdir}/ctdb/events.d/11.natgw
109 %{_sysconfdir}/ctdb/events.d/20.multipathd
110 %{_sysconfdir}/ctdb/events.d/40.vsftpd
111 %{_sysconfdir}/ctdb/events.d/41.httpd
112 %{_sysconfdir}/ctdb/events.d/50.samba
113 %{_sysconfdir}/ctdb/events.d/60.nfs
114 %{_sysconfdir}/ctdb/events.d/61.nfstickle
115 %{_sysconfdir}/ctdb/events.d/70.iscsi
116 %{_sysconfdir}/ctdb/events.d/90.ipmux
117 %{_sysconfdir}/ctdb/events.d/91.lvs
118 %{_sysconfdir}/ctdb/events.d/99.routing
119 %{_sysconfdir}/ctdb/statd-callout
120 %{_sbindir}/ctdbd
121 %{_bindir}/ctdb
122 %{_bindir}/smnotify
123 %{_bindir}/ctdb_ipmux
124 %{_bindir}/ctdb_diagnostics
125 %{_bindir}/onnode
126 %{_mandir}/man1/ctdb.1.gz
127 %{_mandir}/man1/ctdbd.1.gz
128 %{_mandir}/man1/onnode.1.gz
129 %{_includedir}/ctdb.h
130 %{_includedir}/ctdb_private.h
131 %{_libdir}/pkgconfig/ctdb.pc
132
133 %changelog
134 * Wed Apr 8 2009 : Version 1.0.79
135  - From Mathieu Parent: add a ctdb pkgconfig file
136  - Fix bug 6250
137  - add a funciton remove_ip to safely remove an ip from an interface, taking care to workaround an issue with linux alias interfaces.
138  - Update the natgw eventscript to use the safe remove_ip() function
139  - fix a bug in the eventscript child process that would cause the socket to be removed.
140  - dont verify nodemap on banned nodes during cluster monitoring
141  - Update the dodgy SeqnumInterval to have ms resolution
142 * Tue Mar 31 2009 : Version 1.0.78
143  - Add a notify mechanism so we can send snmptraps/email to external management systems when the node becomes unhealthy
144  - include 11.natgw eventscript in thew install so that the NATGW feature works
145 * Tue Mar 31 2009 : Version 1.0.77
146  - Update the 99.routing eventscript to also try to add the routes (back) during a releaseip event. Similar to the reasons why we must add addresses back during releaseip in 10.interfaces
147 * Wed Mar 24 2009 : Version 1.0.76
148  - Add a debugging command "xpnn" which can print the pnn of the node even when ctdbd is not running.
149  - Redo the NATGW implementation to allow multiple disjoing NATGW groups in the same cluster.
150 * Tue Mar 24 2009 : Version 1.0.75
151  - Various updates to LVS
152  - Fix a bug in the killtcp control where we did not set the port correctly
153  - add a new "ctdb scriptstatus" command that shows the status of the eventrscripts.
154 * Mon Mar 16 2009 : Version 1.0.74
155  - Fixes to AIX from C Cowan.
156  - Fixes to ctdb_diagnostics so we collect correct GPFS data
157  - Fixes to the net conf list command in ctdb_diagnostics
158  - Check the static-routes file IFF it exists in ctdb_diagnostics
159 * Wed Mar 4 2009 : Version 1.0.73
160  - Add possibility to disable the check of shares for NFS and Samba
161  - From Sumit Bose, fix dependencies so make -j works
162 * Wed Feb 18 2009 : Version 1.0.72
163  - Updates to test scripts by martin s
164  - Adding a COPYING file
165  - Use netstat to check for services and ports and fallback to netcat
166    only if netstat is unavailable.
167 * Mon Feb 2 2009 : Version 1.0.71
168  - Additional ipv6 fixes from Michael Adams
169 * Fri Jan 16 2009 : Version 1.0.70
170  - IPv6 support is completed. this is backward compatible with ipv4-only
171    systems. To use IPv6 with samba and ctdb you need current GIT of samba 3.3
172    or michael adams samba-ctdeb branch.
173  - Many enhancements to the build system and scripts to make it more SUSE
174    friendly by Michael Adams.
175  - Change of how the naming of the package is structured. We are now
176    using "1.0.70" as a release and "-1" as the revision instead of as
177    previously using "1.0" as release and ".70" as the revision.
178    By Michael Adams.
179 * Thu Dec 18 2008 : Version 1.0.69
180  - Various fixes to scripts by M Adam
181  - Dont call ctdb_fatal() when the transport is down during shutdown
182 * Fri Dec 12 2008 : Version 1.0.68
183  - Fixes for monitoring of interfaces status from Michael Adam.
184  - Use -q instead of >/dev/null for grep to enhance readability of the
185    scripts from Michael Adam.
186  - Update to the "ctdb recover" command. This command now block until the
187    has completed. This makes it much easier to use in scripts and avoids
188    the common workaround :
189       ctdb recover
190       ... loop while waiting for recovery completes ...
191       continue ...
192  - Add a CTDB_TIMEOUT variable. If set, this variable provides an automatic
193    timeout for "ctdb <command>", similar to using -T <timeout>
194  - Set a unique errorcode for "ctdb <command>" when it terminates due to a 
195    timeout so that scripts can distinguish between a hung command and what was
196    just a failure.
197  - Update "ctdb ban/unban" so that if the cluster is in recovery these commands
198    blocks and waits until after recovery is complete before the perform the
199    ban/unban operation. This is necessary since the recovery process can cause
200    nodes to become automatically unbanned.
201  - Update "ctdb ban/unban" to block until the recovery that will follow shortly
202    after this command has completed.
203    This makes it much easier to use in scripts and avoids the common
204    workaround :
205       ctdb ban/unban
206       ... loop while waiting for recovery completes ...
207       continue ...
208  - Bugfix for the new flags handling in 1.0.67. Abort and restart monitoring
209    if we failed to get proper nodemaps from a remote node instead of
210    dereferencing a null pointer.
211  - If ctdbd was explicitely started with the '--socket' argument, make
212    ctdbd automatically set CTDB_SOCKET to the specified argument.
213    This ensures that eventscripts spawned by the ctdb daemon will default to
214    using the same socket and talk to the correct daemon.
215    This primarily affects running multiple daemons on the same host and where 
216    you want each instance of ctdb daemons have their eventscripts talk to the
217    "correct" daemon.
218  - Update "ctdb ping" to return an error code if the ping fail so that it
219    can be used in scripts.
220  - Update to how to synchronize management of node flags across the cluster.
221 * Thu Dec 3 2008 : Version 1.0.67
222  - Add a document describing the recovery process.
223  - Fix a bug in "ctdb setdebug" where it would refuse to set a negative
224    debug level.
225  - Print the list of literals for debug names if an invalid one was given
226    to "ctdb setdebug"
227  - Redesign how "ctdb reloadnodes" works and reduce the amont of tcp teardowns
228    used during this event.
229  - Make it possible to delete a public ip from all nodes at once using
230    "ctdb delip -n all"
231 * Mon Nov 24 2008 : Version 1.0.66
232  - Allow to change the recmaster even when we are not frozen.
233  - Remove two redundant SAMBA_CHECK variables from the sysconf example
234  - After a node failure it can take very long before some lock operations
235    ctdb needs to perform are allowed/works with gpfs again. Workaround this
236    by treating a hang/timeout as success.
237  - Dont override CTDB_BASE is fet in the shell already
238  - Always send keepalive packets regardless of whether the link is idle or not.
239  - Rewrite the disable/enable flag update logic to prevent a race between 
240    "ctdb disable/enable" and the recovery daemon when updating the flags to 
241    all nodes.
242 * Thu Nov 13 2008 : Version 1.0.65
243  - Update the sysconfig example: The default debug level is 2 (NOTICE) and not
244    0 (ERROR)
245  - Add support for a CTDB_SOCKET environment variable for the ctdb command
246    line tool. If set, this overrides the default socket the ctdb tool will
247    use.
248  - Add logging of high latency operations.
249 * Mon Oct 22 2008 : Version 1.0.64
250  - Add a context and a timed event so that once we have been in recovery for
251    too long we drop all public addresses.
252 * Mon Oct 20 2008 : Version 1.0.63
253  - Remove logging of "periodic cleanup ..." in 50.samba
254  - When we reload a nodes file, we must detect this and reload the file also
255    in the recovery daemon before we try to dereference somethoung beyond the end
256    of the nodes array.
257 * Thu Oct 16 2008 : Version 1.0.62
258  - Allow multiple eventscritps using the same prefix number.
259    It is undefined which order scripts with the same prefix will execute in.
260 * Wed Oct 15 2008 : Version 1.0.61
261  - Use "route add -net" instead of "ip route add" when adding routes in 99.routing
262  - lower the loglevel os several debug statements
263  - check the status returned from ctdb_ctrl_get_tickles() before we try to print them out to the screen.
264  - install a new eventscript 20.multipathd whoich can be used to monitor that multipath devices are healthy
265 * Wed Oct 15 2008 : Version 1.0.60
266  - Verify that nodes we try to ban/unban are reachable and print an error othervise.
267  - Update the client and server sides of TAKEIP/RELEASEIP/GETPUBLICIPS and GETNODEMAP to fall back to the old style ipv4-only controls if the new ipv4/ipv6 controls fail. This allows an ipv4/v6 enabled ctdb daemon to interoperate with earlier ipv4-only versions of the daemons.
268  - From Mathieu Parent : log debian systems log the package versions in ctdb diagnostics
269  - From Mathieu Parent : specify logdir location for debian (this patch was later reversed)
270  - From Michael Adams : allow # comments in nodes/public_addresses files
271 * Tue Oct 7 2008 : Version 1.0.59
272  - Updated "reloadnodes" logic. Instead of bouncing the entire tcp layer it is sufficient to just close and reopen all outgoing tcp connections.
273  - New eventscript 99.routing which can be used to re-attach routes to public interfaces after a takeip event. (routes may be deleted by the kernel when we release an ip)
274  - IDR tree fix from Jim Houston
275  - Better handling of critical events if the local clock is suddenly changed forward by a lot.
276  - Fix three slow memory leaks in the recovery daemon
277  - New ctdb command : ctdb recmaster   which prints the pnn of the recmaster
278  - Onnode enhancements from Martin S : "healthy" and "connected" are now possible nodespecifiers
279  - From Martin S : doc fixes
280  - lowering some debug levels for some nonvital informational messages
281  - Make the daemon daemon monitoring stronger and allow ctdbd to detect a hung
282    recovery daemon.
283  - From C Cowan : patches to compile ipv6 under AIX
284  - zero out some structs to keep valgrind happy
285 * Wed Aug 27 2008 : Version 1.0.58
286  - revert the name change tcp_tcp_client back to tcp_control_tcp so
287    samba can build.
288  - Updates to the init script from Abhijith Das <adas@redhat.com>
289 * Mon Aug 25 2008 : Version 1.0.57
290  - initial support for IPv6
291 * Mon Aug 11 2008 : Version 1.0.56
292  - fix a memory leak in the recovery daemon.
293 * Mon Aug 11 2008 : Version 1.0.55
294  - Fix the releaseip message we seond to samba.
295 * Fri Aug 8 2008 : Version 1.0.54
296  - fix a looping error in the transaction code
297  - provide a more detailed error code for persistent store errors
298    so clients can make more intelligent choices on how to try to recover
299 * Thu Aug 7 2008 : Version 1.0.53
300  - Remove the reclock.pnn file   it can cause gpfs to fail to umount
301  - New transaction code
302 * Mon Aug 4 2008 : Version 1.0.52
303  - Send an explicit gratious arp when starting sending the tcp tickles.
304  - When doing failover, issue a killtcp to non-NFS/non-CIFS clients
305    so that they fail quickly. NFS and CIFS already fail and recover 
306    quickly.
307  - Update the test scripts to handle CTRL-C to kill off the test.
308 * Mon Jul 28 2008 : Version 1.0.51
309  - Strip off the vlan tag from bond devices before we check in /proc
310    if the interface is up or not.
311  - Use testparm in the background in the scripts to allow probing
312    that the shares do exist.
313  - Fix a bug in the logging code to handle multiline entries better
314  - Rename private elements from private to private_data
315 * Fri Jul 18 2008 : Version 1.0.50
316  - Dont assume that just because we can establish a TCP connection
317    that we are actually talking to a functioning ctdb daemon.
318    So dont mark the node as CONNECTED just because the tcp handshake
319    was successful.
320  - Dont try to set the recmaster to ourself during elections for those
321    cases we know this will fail. To remove some annoying benign but scary
322    looking entries from the log.
323  - Bugfix for eventsystem for signal handling that could cause a node to
324    hang.
325 * Thu Jul 17 2008 : Version 1.0.49
326  - Update the safe persistent update fix to work with unpatched samba
327    servers.
328 * Thu Jul 17 2008 : Version 1.0.48
329  - Update the spec file.
330  - Do not start new user-triggered eventscripts if we are already
331    inside recovery mode.
332  - Add two new controls to start/cancel a persistent update.
333    A client such as samba can use these to tell ctdbd that it will soon
334    be writing directly to the persistent database tdb file. So if
335    samba is -9ed before it has eitehr done the persistent_store or
336    canceled the operation, ctdb knows that the persistent databases
337    'may' be out of sync and therefore a full blown recovery is called for.
338  - Add two new options :
339    CTDB_SAMBA_SKIP_CONF_CHECK and CTDB_SAMBA_CHECK_PORTS that can be used
340    to override what checks to do when monitoring samba health.
341    We can no longer use the smbstatus, net or testparm commands to check
342    if samba or its config is healthy since these commands may block
343    indefinitely and thus can not be used in scripts.
344 * Fri Jul 11 2008 : Version 1.0.47
345  - Fix a double free bug where if a user striggered (ctdb eventscript)
346    hung and while the timeout handler was being processed a new user
347    triggered eventscript was started we would free state twice.
348  - Rewrite of onnode and associated documentation.
349 * Thu Jul 10 2008 : Version 1.0.46
350  - Document both the LVS:cingle-ip-address and the REMOTE-NODE:wan-accelerator
351    capabilities.
352  - Add commands "ctdb pnn", "ctdb lvs", "ctdb lvsmaster".
353  - LVS improvements. LVS is the single-ip-address mode for a ctdb cluster.
354  - Fixes to supress rpmlint warnings
355  - AXI compile fixes.
356  - Change \s to [[:space:]] in some scripts. Not all RHEL5 packages come
357    with a egrep that handles \s   even same version but different arch.
358  - Revert the change to NFS restart. CTDB should NOT attempt to restart
359    failed services.
360  - Rewrite of the waitpid() patch to use the eventsystem for handling
361    signals.
362 * Tue Jul 8 2008 : Version 1.0.45
363  - Try to restart the nfs service if it has failed to respond 3 times in a row.
364  - waitpid() can block if the child does not respond promptly to SIGTERM.
365    ignore all SIGCHILD signals by setting SIGCHLD to SIG_DEF.
366    get rid of all calls to waitpid().
367  - make handling of eventscripts hanging more liberal.
368    only consider the script to have failed and making the node unhealthy
369    IF the eventscript terminated wiht an error
370    OR the eventscript hung 5 or more times in a row
371 * Mon Jul 7 2008 : Version 1.0.44
372  - Add a CTDB_VALGRIND option to /etc/sysconfig/ctdb to make it start
373    ctdb under valgrind. Logs go to /var/log/ctdb_valgrind.PID
374  - Add a hack to show the control opcode that caused uninitialized data
375    in the valgrind output by encoding the opcode as the line number.
376  - Initialize structures and allocated memory in various places in
377    ctdb to make it valgrind-clean and remove all valgrind errors/warnings.
378  - If/when we destroy a lockwait child, also make sure we cancel any pending transactions
379  - If a transaction_commit fails, delete/cancel any pending transactions and
380    return an error instead of calling ctdb_fatal()
381  - When running ctdb under valgrind, make sure we run it with --nosetsched and also
382    ensure that we do not use mem-mapped i/o when accessing the tdb's.
383  - zero out ctdb->freeze_handle when we free/destroy a freeze-child.
384    This prevent a heap corruption/ctdb crash bug that could trigger
385    if the freeze child times out.
386  - we dont need to explicitely thaw the databases from the recovery daemon
387    since this is done implicitely when we restore the recovery mode back to normal.
388  - track when we start and stop a recovery. Add the 'time it took to complete the
389    recovery' to the 'ctdb uptime' output.
390    Ensure by tracking the start/stop recovery timestamps that we do not
391    check that the ip allocation is consistend from inside the recovery daemon
392    while a different node (recovery master) is performing a recovery.
393    This prevent a race that could cause a full recovery to trigger if the
394    'ctdb disable/enable' commands took very long.
395  - The freeze child indicates to the master daemon that all databases are locked
396    by writing data to the pipe shared with the master daemon.
397    This write sometimes fail and thus the master daemon never notices that the databases
398    are locked cvausing long timeouts and extra recoveries.
399    Check that the write is successful and try the write again if it failed.
400  - In each node, verify that the recmaster have the right node flags for us
401    and force a push of our flags to the recmaster if wrong.
402 * Tue Jul 1 2008 : Version 1.0.43
403  - Updates and bugfixes to the specfile to keep rpmlint happy
404  - Force a global flags update after each recovery event.
405  - Verify that the recmaster agrees with our node flags and update the
406    recmaster othervise.
407  - When writing back to the parent from a freeze-child across the pipe,
408    loop over the write in case the write failed with an error  othervise
409    the parent will never be notified tha the child has completed the operation.
410  - Automatically thaw all databases when recmaster marks us as being in normal
411    mode instead of recovery mode.
412 * Fri Jun 13 2008 : Version 1.0.42
413  - When event scripts have hung/timedout more than EventScriptBanCount times
414    in a row the node will ban itself.
415  - Many updates to persistent write tests and the test scripts.
416 * Wed May 28 2008 : Version 1.0.41
417  - Reactivate the safe writes to persistent databases and solve the
418    locking issues. Locking issues are solved the only possible way,
419    by using a child process to do the writes.  Expensive and slow but... . 
420 * Tue May 27 2008 : Version 1.0.40
421  - Read the samba sysconfig file from the 50.samba eventscript
422  - Fix some emmory hierarchical bugs in the persistent write handling
423 * Thu May 22 2008 : Version 1.0.39
424  - Moved a CTDB_MANAGES_NFS, CTDB_MANAGES_ISCSI and CTDB_MANAGES_CSFTPD
425    into /etc/sysconfig/ctdb
426  - Lowered some debug messages to not fill the logfile with entries
427    that normally occur in the default configuration.
428 * Fri May 16 2008 : Version 1.0.38
429  - Add machine readable output support to "ctdb getmonmode"
430  - Lots of tweaks and enhancements if the event scripts are "slow"
431  - Merge from tridge: an attempt to break the chicken-and-egg deadlock that
432    net conf introduces if used from an eventscript.
433  - Enhance tickles so we can tickle an ipv6 connection.
434  - Start adding ipv6 support : create a new container to replace sockaddr_in.
435  - Add a checksum routine for ipv6/tcp
436  - When starting up ctdb, let the init script do a tdbdump on all
437    persistent databases and verify that they are good (i.e. not corrupted).
438  - Try to use "safe transactions" when writing to a persistent database
439    that was opened with the TDB_NOSYNC flag. If we can get the transaction
440    thats great, if we cant  we have to write anyway since we cant block here.
441 * Mon May 12 2008 : Version 1.0.37
442  - When we shutdown ctdb we close the transport down before we run the 
443    "shutdown" eventscripts. If ctdb decides to send a packet to a remote node
444    after we have shutdown the transport but before we have shutdown ctdbd
445    itself this could lead to a SEGV instead of a clean shutdown. Fix.
446  - When using the "exportfs" command to extract which NFS export directories
447    to monitor,  exportfs violates the "principle of least surprise" and
448    sometimes report a single export line as two lines of text output
449    causing the monitoring to fail.
450 * Fri May 9 2008 : Version 1.0.36
451  - fix a memory corruption bug that could cause the recovery daemon to crash.
452  - fix a bug with distributing public ip addresses during recovery.
453    If the node that is the recovery master did NOT use public addresses,
454    then it assumed that no other node in the cluster used them either and
455    thus skipped the entire step of reallocating public addresses.
456 * Wed May 7 2008 : Version 1.0.35
457  - During recovery, when we define the new set of lmasters (vnnmap)
458    only consider those nodes that have the can-be-lmaster capability
459    when we create the vnnmap. unless there are no nodes available which
460    supports this capability in which case we allow the recmaster to
461    become lmaster capable (temporarily).
462  - Extend the async framework so that we can use paralell async calls
463    to controls that return data.
464  - If we do not have the "can be recmaster" capability, make sure we will
465    lose any recmaster elections, unless there are no nodes available that
466    have the capability, in which case we "take/win" the election anyway.
467  - Close and reopen the reclock pnn file at regular intervals.
468    Make it a non-fatal event if we occasionally fail to open/read/write
469    to this file.
470  - Monitor that the recovery daemon is still running from the main ctdb
471    daemon and shutdown the main daemon when recovery daemon has terminated.
472  - Add a "ctdb getcapabilities" command to read the capabilities off a node.
473  - Define two new capabilities : can be recmaster and can be lmaster
474    and default both capabilities to YES.
475  - Log denied tcp connection attempts with DEBUG_ERR and not DEBUG_WARNING
476 * Thu Apr 24 2008 : Version 1.0.34
477  - When deleting a public ip from a node, try to migrate the ip to a different
478    node first.
479  - Change catdb to produce output similar to tdbdump
480  - When adding a new public ip address, if this ip does not exist yet in
481    the cluster, then grab the ip on the local node and activate it.
482  - When a node disagrees with the recmaster on WHO is the recmaster, then
483    mark that node as a recovery culprit so it will eventually become
484    banned.
485  - Make ctdb eventscript support the -n all argument.
486 * Thu Apr 10 2008 : Version 1.0.33
487  - Add facilities to include site local adaptations to the eventscript
488    by /etc/ctdb/rc.local which will be read by all eventscripts.
489  - Add a "ctdb version" command.
490  - Secure the domain socket with proper permissions from Chris Cowan
491  - Bugfixes for AIX from Chris Cowan
492 * Wed Apr 02 2008 : Version 1.0.32
493  - Add a control to have a node execute the eventscripts with arbitrary
494    command line arguments.
495  - Add a control "rddumpmemory" that will dump the talloc memory allocations
496    for the recovery daemon.
497  - Decorate the talloc memdump to produce better and easier memory leak
498    tracking. 
499  - Update the RHEL5 iscsi tgtd scripts to allow one iscsi target for each
500    public address.
501  - Add two new controls "addip/delip" that can be used to add/remove public
502    addresses to a node at runtime. After using these controls a "ctdb recover"
503    ir required to make the changes take.
504  - Fix a couple of slow memory leaks.
505 * Tue Mar 25 2008 : Version 1.0.31
506  - Add back controls to disable/enable monitoring on a node.
507  - Fix a memory leak where we used to attach CALL data to the ctdb structure
508    when performing a local call. Memory which would be lost if the call was
509    aborted.
510  - Reduce the loglevel for the log output when someone connects to a non
511    public ip address for samba.
512  - Redo and optimize the vacuuming process to send only one control to each
513    other node containing all records to be vacuumed instead of one
514    control per node per record.
515 * Tue Mar 04 2008 : Version 1.0.30
516  - Update documentation cor new commands and tuneables
517  - Add machinereadable output to the ip,uptime and getdebug commands
518  - Add a moveip command to manually failover/failback public ips
519  - Add NoIPFallback tuneable that prevents ip address failback
520  - Use file locking inside the CFS as alternative to verify when other nodes
521    Are connected/disconnected to be able to recover from split network
522  - Add DisableWhenUnhealthy tunable
523  - Add CTDB_START_AS_DISABLED sysconfig param
524  - Add --start-as-disabled flag to ctdb
525  - Add ability to monitor for OOM condition
526 * Thu Feb 21 2008 : Version 1.0.29
527  - Add a new command to make expansion of an existing cluster easier
528  - Fix bug with references to freed objects in the ctdb structure
529  - Propagate debuglevel changes to the recovery daemon
530  - Merge patches to event scripts from Mathieu Parent :
531  - MP: Simulate "service" on systems which do not provide this tool
532  - MP: Set correct permissions for events.d/README
533  - Add nice helper functions to start/stop nfs from the event scripts
534 * Fri Feb 08 2008 : Version 1.0.28
535  - Fix a problem where we tried to use ethtool on non-ethernet interfaces
536  - Warn if the ipvsadm packege is missing when LVS is used
537  - Dont use absolute pathnames in some of the event scripts
538  - Fix for persistent tdbs growing inifinitely.
539 * Wed Feb 06 2008 : Version 1.0.27
540  - Add eventscript for iscsi
541 * Thu Jan 31 2008 : Version 1.0.26
542  - Fix crashbug in tdb transaction code
543 * Tue Jan 29 2008 : Version 1.0.25
544  - added async recovery code
545  - make event scripts more portable
546  - fixed ctdb dumpmemory
547  - more efficient tdb allocation code
548  - improved machine readable ctdb status output
549  - added ctdb uptime
550 * Wed Jan 16 2008 : Version 1.0.24
551  - added syslog support
552  - documentation updates
553 * Wed Jan 16 2008 : Version 1.0.23
554  - fixed a memory leak in the recoveryd
555  - fixed a corruption bug in the new transaction code
556  - fixed a case where an packet for a disconnected client could be processed
557  - added http event script
558  - updated documentation
559 * Thu Jan 10 2008 : Version 1.0.22
560  - auto-run vacuum and repack ops
561 * Wed Jan 09 2008 : Version 1.0.21
562  - added ctdb vacuum and ctdb repack code
563 * Sun Jan 06 2008 : Version 1.0.20
564  - new transaction based recovery code
565 * Sat Jan 05 2008 : Version 1.0.19
566  - fixed non-master bug
567  - big speedup in recovery for large databases
568  - lots of changes to improve tdb and ctdb for high churn databases
569 * Thu Dec 27 2007 : Version 1.0.18
570  - fixed crash bug in monitor_handler
571 * Tue Dec 04 2007 : Version 1.0.17
572  - fixed bugs related to ban/unban of nodes
573  - fixed a race condition that could lead to monitoring being permanently disabled,
574    which would lead to long recovery times
575  - make deterministic IPs the default
576  - fixed a bug related to continuous recovery 
577  - added a debugging option --node-ip