new version 1.0.76
[sahlberg/ctdb.git] / packaging / RPM / ctdb.spec
1 %define initdir %{_sysconfdir}/init.d
2
3 Summary: Clustered TDB
4 Vendor: Samba Team
5 Packager: Samba Team <samba@samba.org>
6 Name: ctdb
7 Version: 1.0.76
8 Release: 1
9 Epoch: 0
10 License: GNU GPL version 3
11 Group: System Environment/Daemons
12 URL: http://ctdb.samba.org/
13
14 Source: ctdb-%{version}.tar.gz
15
16 Prereq: /sbin/chkconfig /bin/mktemp /usr/bin/killall
17 Prereq: fileutils sed /etc/init.d
18
19 Provides: ctdb = %{version}
20
21 Prefix: /usr
22 BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24 %description
25 ctdb is the clustered database used by samba
26
27
28 #######################################################################
29
30 %prep
31 %setup -q
32 # setup the init script and sysconfig file
33 %setup -T -D -n ctdb-%{version} -q
34
35 %build
36
37 ## check for ccache
38 if ccache -h >/dev/null 2>&1 ; then
39         CC="ccache gcc"
40 else
41         CC="gcc"
42 fi
43
44 export CC
45
46 ## always run autogen.sh
47 ./autogen.sh
48
49 CFLAGS="$RPM_OPT_FLAGS $EXTRA -O0 -D_GNU_SOURCE -DCTDB_VERS=\"%{version}-%{release}\"" ./configure \
50         --prefix=%{_prefix} \
51         --sysconfdir=%{_sysconfdir} \
52         --mandir=%{_mandir} \
53         --localstatedir="/var"
54
55 make docdir=%{_docdir} showflags
56 make docdir=%{_docdir}
57
58 %install
59 # Clean up in case there is trash left from a previous build
60 rm -rf $RPM_BUILD_ROOT
61
62 # Create the target build directory hierarchy
63 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
64 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
65
66 make DESTDIR=$RPM_BUILD_ROOT docdir=%{_docdir} install
67
68 install -m644 config/ctdb.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ctdb
69 install -m755 config/ctdb.init $RPM_BUILD_ROOT%{initdir}/ctdb
70
71 # Remove "*.old" files
72 find $RPM_BUILD_ROOT -name "*.old" -exec rm -f {} \;
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 [ -x /sbin/chkconfig ] && /sbin/chkconfig --add ctdb
79
80 %preun
81 if [ $1 = 0 ] ; then
82     [ -x /sbin/chkconfig ] && /sbin/chkconfig --del ctdb
83 fi
84 exit 0
85
86 %postun
87 if [ "$1" -ge "1" ]; then
88         %{initdir}/ctdb restart >/dev/null 2>&1 || true
89 fi      
90
91
92 #######################################################################
93 ## Files section                                                     ##
94 #######################################################################
95
96 %files
97 %defattr(-,root,root)
98
99 %config(noreplace) %{_sysconfdir}/sysconfig/ctdb
100 %config(noreplace) %{_sysconfdir}/ctdb/functions
101 %attr(755,root,root) %{initdir}/ctdb
102
103 %{_docdir}/ctdb/README.eventscripts
104 %{_docdir}/ctdb/recovery-process.txt
105 %{_sysconfdir}/ctdb/events.d/00.ctdb
106 %{_sysconfdir}/ctdb/events.d/10.interface
107 %{_sysconfdir}/ctdb/events.d/20.multipathd
108 %{_sysconfdir}/ctdb/events.d/40.vsftpd
109 %{_sysconfdir}/ctdb/events.d/41.httpd
110 %{_sysconfdir}/ctdb/events.d/50.samba
111 %{_sysconfdir}/ctdb/events.d/60.nfs
112 %{_sysconfdir}/ctdb/events.d/61.nfstickle
113 %{_sysconfdir}/ctdb/events.d/70.iscsi
114 %{_sysconfdir}/ctdb/events.d/90.ipmux
115 %{_sysconfdir}/ctdb/events.d/91.lvs
116 %{_sysconfdir}/ctdb/events.d/99.routing
117 %{_sysconfdir}/ctdb/statd-callout
118 %{_sbindir}/ctdbd
119 %{_bindir}/ctdb
120 %{_bindir}/smnotify
121 %{_bindir}/ctdb_ipmux
122 %{_bindir}/ctdb_diagnostics
123 %{_bindir}/onnode
124 %{_mandir}/man1/ctdb.1.gz
125 %{_mandir}/man1/ctdbd.1.gz
126 %{_mandir}/man1/onnode.1.gz
127 %{_includedir}/ctdb.h
128 %{_includedir}/ctdb_private.h
129
130 %changelog
131 * Wed Mar 24 2009 : Version 1.0.76
132  - Add a debugging command "xpnn" which can print the pnn of the node even when ctdbd is not running.
133  - Redo the NATGW implementation to allow multiple disjoing NATGW groups in the same cluster.
134 * Tue Mar 24 2009 : Version 1.0.75
135  - Various updates to LVS
136  - Fix a bug in the killtcp control where we did not set the port correctly
137  - add a new "ctdb scriptstatus" command that shows the status of the eventrscripts.
138 * Mon Mar 16 2009 : Version 1.0.74
139  - Fixes to AIX from C Cowan.
140  - Fixes to ctdb_diagnostics so we collect correct GPFS data
141  - Fixes to the net conf list command in ctdb_diagnostics
142  - Check the static-routes file IFF it exists in ctdb_diagnostics
143 * Wed Mar 4 2009 : Version 1.0.73
144  - Add possibility to disable the check of shares for NFS and Samba
145  - From Sumit Bose, fix dependencies so make -j works
146 * Wed Feb 18 2009 : Version 1.0.72
147  - Updates to test scripts by martin s
148  - Adding a COPYING file
149  - Use netstat to check for services and ports and fallback to netcat
150    only if netstat is unavailable.
151 * Mon Feb 2 2009 : Version 1.0.71
152  - Additional ipv6 fixes from Michael Adams
153 * Fri Jan 16 2009 : Version 1.0.70
154  - IPv6 support is completed. this is backward compatible with ipv4-only
155    systems. To use IPv6 with samba and ctdb you need current GIT of samba 3.3
156    or michael adams samba-ctdeb branch.
157  - Many enhancements to the build system and scripts to make it more SUSE
158    friendly by Michael Adams.
159  - Change of how the naming of the package is structured. We are now
160    using "1.0.70" as a release and "-1" as the revision instead of as
161    previously using "1.0" as release and ".70" as the revision.
162    By Michael Adams.
163 * Thu Dec 18 2008 : Version 1.0.69
164  - Various fixes to scripts by M Adam
165  - Dont call ctdb_fatal() when the transport is down during shutdown
166 * Fri Dec 12 2008 : Version 1.0.68
167  - Fixes for monitoring of interfaces status from Michael Adam.
168  - Use -q instead of >/dev/null for grep to enhance readability of the
169    scripts from Michael Adam.
170  - Update to the "ctdb recover" command. This command now block until the
171    has completed. This makes it much easier to use in scripts and avoids
172    the common workaround :
173       ctdb recover
174       ... loop while waiting for recovery completes ...
175       continue ...
176  - Add a CTDB_TIMEOUT variable. If set, this variable provides an automatic
177    timeout for "ctdb <command>", similar to using -T <timeout>
178  - Set a unique errorcode for "ctdb <command>" when it terminates due to a 
179    timeout so that scripts can distinguish between a hung command and what was
180    just a failure.
181  - Update "ctdb ban/unban" so that if the cluster is in recovery these commands
182    blocks and waits until after recovery is complete before the perform the
183    ban/unban operation. This is necessary since the recovery process can cause
184    nodes to become automatically unbanned.
185  - Update "ctdb ban/unban" to block until the recovery that will follow shortly
186    after this command has completed.
187    This makes it much easier to use in scripts and avoids the common
188    workaround :
189       ctdb ban/unban
190       ... loop while waiting for recovery completes ...
191       continue ...
192  - Bugfix for the new flags handling in 1.0.67. Abort and restart monitoring
193    if we failed to get proper nodemaps from a remote node instead of
194    dereferencing a null pointer.
195  - If ctdbd was explicitely started with the '--socket' argument, make
196    ctdbd automatically set CTDB_SOCKET to the specified argument.
197    This ensures that eventscripts spawned by the ctdb daemon will default to
198    using the same socket and talk to the correct daemon.
199    This primarily affects running multiple daemons on the same host and where 
200    you want each instance of ctdb daemons have their eventscripts talk to the
201    "correct" daemon.
202  - Update "ctdb ping" to return an error code if the ping fail so that it
203    can be used in scripts.
204  - Update to how to synchronize management of node flags across the cluster.
205 * Thu Dec 3 2008 : Version 1.0.67
206  - Add a document describing the recovery process.
207  - Fix a bug in "ctdb setdebug" where it would refuse to set a negative
208    debug level.
209  - Print the list of literals for debug names if an invalid one was given
210    to "ctdb setdebug"
211  - Redesign how "ctdb reloadnodes" works and reduce the amont of tcp teardowns
212    used during this event.
213  - Make it possible to delete a public ip from all nodes at once using
214    "ctdb delip -n all"
215 * Mon Nov 24 2008 : Version 1.0.66
216  - Allow to change the recmaster even when we are not frozen.
217  - Remove two redundant SAMBA_CHECK variables from the sysconf example
218  - After a node failure it can take very long before some lock operations
219    ctdb needs to perform are allowed/works with gpfs again. Workaround this
220    by treating a hang/timeout as success.
221  - Dont override CTDB_BASE is fet in the shell already
222  - Always send keepalive packets regardless of whether the link is idle or not.
223  - Rewrite the disable/enable flag update logic to prevent a race between 
224    "ctdb disable/enable" and the recovery daemon when updating the flags to 
225    all nodes.
226 * Thu Nov 13 2008 : Version 1.0.65
227  - Update the sysconfig example: The default debug level is 2 (NOTICE) and not
228    0 (ERROR)
229  - Add support for a CTDB_SOCKET environment variable for the ctdb command
230    line tool. If set, this overrides the default socket the ctdb tool will
231    use.
232  - Add logging of high latency operations.
233 * Mon Oct 22 2008 : Version 1.0.64
234  - Add a context and a timed event so that once we have been in recovery for
235    too long we drop all public addresses.
236 * Mon Oct 20 2008 : Version 1.0.63
237  - Remove logging of "periodic cleanup ..." in 50.samba
238  - When we reload a nodes file, we must detect this and reload the file also
239    in the recovery daemon before we try to dereference somethoung beyond the end
240    of the nodes array.
241 * Thu Oct 16 2008 : Version 1.0.62
242  - Allow multiple eventscritps using the same prefix number.
243    It is undefined which order scripts with the same prefix will execute in.
244 * Wed Oct 15 2008 : Version 1.0.61
245  - Use "route add -net" instead of "ip route add" when adding routes in 99.routing
246  - lower the loglevel os several debug statements
247  - check the status returned from ctdb_ctrl_get_tickles() before we try to print them out to the screen.
248  - install a new eventscript 20.multipathd whoich can be used to monitor that multipath devices are healthy
249 * Wed Oct 15 2008 : Version 1.0.60
250  - Verify that nodes we try to ban/unban are reachable and print an error othervise.
251  - Update the client and server sides of TAKEIP/RELEASEIP/GETPUBLICIPS and GETNODEMAP to fall back to the old style ipv4-only controls if the new ipv4/ipv6 controls fail. This allows an ipv4/v6 enabled ctdb daemon to interoperate with earlier ipv4-only versions of the daemons.
252  - From Mathieu Parent : log debian systems log the package versions in ctdb diagnostics
253  - From Mathieu Parent : specify logdir location for debian (this patch was later reversed)
254  - From Michael Adams : allow # comments in nodes/public_addresses files
255 * Tue Oct 7 2008 : Version 1.0.59
256  - Updated "reloadnodes" logic. Instead of bouncing the entire tcp layer it is sufficient to just close and reopen all outgoing tcp connections.
257  - New eventscript 99.routing which can be used to re-attach routes to public interfaces after a takeip event. (routes may be deleted by the kernel when we release an ip)
258  - IDR tree fix from Jim Houston
259  - Better handling of critical events if the local clock is suddenly changed forward by a lot.
260  - Fix three slow memory leaks in the recovery daemon
261  - New ctdb command : ctdb recmaster   which prints the pnn of the recmaster
262  - Onnode enhancements from Martin S : "healthy" and "connected" are now possible nodespecifiers
263  - From Martin S : doc fixes
264  - lowering some debug levels for some nonvital informational messages
265  - Make the daemon daemon monitoring stronger and allow ctdbd to detect a hung
266    recovery daemon.
267  - From C Cowan : patches to compile ipv6 under AIX
268  - zero out some structs to keep valgrind happy
269 * Wed Aug 27 2008 : Version 1.0.58
270  - revert the name change tcp_tcp_client back to tcp_control_tcp so
271    samba can build.
272  - Updates to the init script from Abhijith Das <adas@redhat.com>
273 * Mon Aug 25 2008 : Version 1.0.57
274  - initial support for IPv6
275 * Mon Aug 11 2008 : Version 1.0.56
276  - fix a memory leak in the recovery daemon.
277 * Mon Aug 11 2008 : Version 1.0.55
278  - Fix the releaseip message we seond to samba.
279 * Fri Aug 8 2008 : Version 1.0.54
280  - fix a looping error in the transaction code
281  - provide a more detailed error code for persistent store errors
282    so clients can make more intelligent choices on how to try to recover
283 * Thu Aug 7 2008 : Version 1.0.53
284  - Remove the reclock.pnn file   it can cause gpfs to fail to umount
285  - New transaction code
286 * Mon Aug 4 2008 : Version 1.0.52
287  - Send an explicit gratious arp when starting sending the tcp tickles.
288  - When doing failover, issue a killtcp to non-NFS/non-CIFS clients
289    so that they fail quickly. NFS and CIFS already fail and recover 
290    quickly.
291  - Update the test scripts to handle CTRL-C to kill off the test.
292 * Mon Jul 28 2008 : Version 1.0.51
293  - Strip off the vlan tag from bond devices before we check in /proc
294    if the interface is up or not.
295  - Use testparm in the background in the scripts to allow probing
296    that the shares do exist.
297  - Fix a bug in the logging code to handle multiline entries better
298  - Rename private elements from private to private_data
299 * Fri Jul 18 2008 : Version 1.0.50
300  - Dont assume that just because we can establish a TCP connection
301    that we are actually talking to a functioning ctdb daemon.
302    So dont mark the node as CONNECTED just because the tcp handshake
303    was successful.
304  - Dont try to set the recmaster to ourself during elections for those
305    cases we know this will fail. To remove some annoying benign but scary
306    looking entries from the log.
307  - Bugfix for eventsystem for signal handling that could cause a node to
308    hang.
309 * Thu Jul 17 2008 : Version 1.0.49
310  - Update the safe persistent update fix to work with unpatched samba
311    servers.
312 * Thu Jul 17 2008 : Version 1.0.48
313  - Update the spec file.
314  - Do not start new user-triggered eventscripts if we are already
315    inside recovery mode.
316  - Add two new controls to start/cancel a persistent update.
317    A client such as samba can use these to tell ctdbd that it will soon
318    be writing directly to the persistent database tdb file. So if
319    samba is -9ed before it has eitehr done the persistent_store or
320    canceled the operation, ctdb knows that the persistent databases
321    'may' be out of sync and therefore a full blown recovery is called for.
322  - Add two new options :
323    CTDB_SAMBA_SKIP_CONF_CHECK and CTDB_SAMBA_CHECK_PORTS that can be used
324    to override what checks to do when monitoring samba health.
325    We can no longer use the smbstatus, net or testparm commands to check
326    if samba or its config is healthy since these commands may block
327    indefinitely and thus can not be used in scripts.
328 * Fri Jul 11 2008 : Version 1.0.47
329  - Fix a double free bug where if a user striggered (ctdb eventscript)
330    hung and while the timeout handler was being processed a new user
331    triggered eventscript was started we would free state twice.
332  - Rewrite of onnode and associated documentation.
333 * Thu Jul 10 2008 : Version 1.0.46
334  - Document both the LVS:cingle-ip-address and the REMOTE-NODE:wan-accelerator
335    capabilities.
336  - Add commands "ctdb pnn", "ctdb lvs", "ctdb lvsmaster".
337  - LVS improvements. LVS is the single-ip-address mode for a ctdb cluster.
338  - Fixes to supress rpmlint warnings
339  - AXI compile fixes.
340  - Change \s to [[:space:]] in some scripts. Not all RHEL5 packages come
341    with a egrep that handles \s   even same version but different arch.
342  - Revert the change to NFS restart. CTDB should NOT attempt to restart
343    failed services.
344  - Rewrite of the waitpid() patch to use the eventsystem for handling
345    signals.
346 * Tue Jul 8 2008 : Version 1.0.45
347  - Try to restart the nfs service if it has failed to respond 3 times in a row.
348  - waitpid() can block if the child does not respond promptly to SIGTERM.
349    ignore all SIGCHILD signals by setting SIGCHLD to SIG_DEF.
350    get rid of all calls to waitpid().
351  - make handling of eventscripts hanging more liberal.
352    only consider the script to have failed and making the node unhealthy
353    IF the eventscript terminated wiht an error
354    OR the eventscript hung 5 or more times in a row
355 * Mon Jul 7 2008 : Version 1.0.44
356  - Add a CTDB_VALGRIND option to /etc/sysconfig/ctdb to make it start
357    ctdb under valgrind. Logs go to /var/log/ctdb_valgrind.PID
358  - Add a hack to show the control opcode that caused uninitialized data
359    in the valgrind output by encoding the opcode as the line number.
360  - Initialize structures and allocated memory in various places in
361    ctdb to make it valgrind-clean and remove all valgrind errors/warnings.
362  - If/when we destroy a lockwait child, also make sure we cancel any pending transactions
363  - If a transaction_commit fails, delete/cancel any pending transactions and
364    return an error instead of calling ctdb_fatal()
365  - When running ctdb under valgrind, make sure we run it with --nosetsched and also
366    ensure that we do not use mem-mapped i/o when accessing the tdb's.
367  - zero out ctdb->freeze_handle when we free/destroy a freeze-child.
368    This prevent a heap corruption/ctdb crash bug that could trigger
369    if the freeze child times out.
370  - we dont need to explicitely thaw the databases from the recovery daemon
371    since this is done implicitely when we restore the recovery mode back to normal.
372  - track when we start and stop a recovery. Add the 'time it took to complete the
373    recovery' to the 'ctdb uptime' output.
374    Ensure by tracking the start/stop recovery timestamps that we do not
375    check that the ip allocation is consistend from inside the recovery daemon
376    while a different node (recovery master) is performing a recovery.
377    This prevent a race that could cause a full recovery to trigger if the
378    'ctdb disable/enable' commands took very long.
379  - The freeze child indicates to the master daemon that all databases are locked
380    by writing data to the pipe shared with the master daemon.
381    This write sometimes fail and thus the master daemon never notices that the databases
382    are locked cvausing long timeouts and extra recoveries.
383    Check that the write is successful and try the write again if it failed.
384  - In each node, verify that the recmaster have the right node flags for us
385    and force a push of our flags to the recmaster if wrong.
386 * Tue Jul 1 2008 : Version 1.0.43
387  - Updates and bugfixes to the specfile to keep rpmlint happy
388  - Force a global flags update after each recovery event.
389  - Verify that the recmaster agrees with our node flags and update the
390    recmaster othervise.
391  - When writing back to the parent from a freeze-child across the pipe,
392    loop over the write in case the write failed with an error  othervise
393    the parent will never be notified tha the child has completed the operation.
394  - Automatically thaw all databases when recmaster marks us as being in normal
395    mode instead of recovery mode.
396 * Fri Jun 13 2008 : Version 1.0.42
397  - When event scripts have hung/timedout more than EventScriptBanCount times
398    in a row the node will ban itself.
399  - Many updates to persistent write tests and the test scripts.
400 * Wed May 28 2008 : Version 1.0.41
401  - Reactivate the safe writes to persistent databases and solve the
402    locking issues. Locking issues are solved the only possible way,
403    by using a child process to do the writes.  Expensive and slow but... . 
404 * Tue May 27 2008 : Version 1.0.40
405  - Read the samba sysconfig file from the 50.samba eventscript
406  - Fix some emmory hierarchical bugs in the persistent write handling
407 * Thu May 22 2008 : Version 1.0.39
408  - Moved a CTDB_MANAGES_NFS, CTDB_MANAGES_ISCSI and CTDB_MANAGES_CSFTPD
409    into /etc/sysconfig/ctdb
410  - Lowered some debug messages to not fill the logfile with entries
411    that normally occur in the default configuration.
412 * Fri May 16 2008 : Version 1.0.38
413  - Add machine readable output support to "ctdb getmonmode"
414  - Lots of tweaks and enhancements if the event scripts are "slow"
415  - Merge from tridge: an attempt to break the chicken-and-egg deadlock that
416    net conf introduces if used from an eventscript.
417  - Enhance tickles so we can tickle an ipv6 connection.
418  - Start adding ipv6 support : create a new container to replace sockaddr_in.
419  - Add a checksum routine for ipv6/tcp
420  - When starting up ctdb, let the init script do a tdbdump on all
421    persistent databases and verify that they are good (i.e. not corrupted).
422  - Try to use "safe transactions" when writing to a persistent database
423    that was opened with the TDB_NOSYNC flag. If we can get the transaction
424    thats great, if we cant  we have to write anyway since we cant block here.
425 * Mon May 12 2008 : Version 1.0.37
426  - When we shutdown ctdb we close the transport down before we run the 
427    "shutdown" eventscripts. If ctdb decides to send a packet to a remote node
428    after we have shutdown the transport but before we have shutdown ctdbd
429    itself this could lead to a SEGV instead of a clean shutdown. Fix.
430  - When using the "exportfs" command to extract which NFS export directories
431    to monitor,  exportfs violates the "principle of least surprise" and
432    sometimes report a single export line as two lines of text output
433    causing the monitoring to fail.
434 * Fri May 9 2008 : Version 1.0.36
435  - fix a memory corruption bug that could cause the recovery daemon to crash.
436  - fix a bug with distributing public ip addresses during recovery.
437    If the node that is the recovery master did NOT use public addresses,
438    then it assumed that no other node in the cluster used them either and
439    thus skipped the entire step of reallocating public addresses.
440 * Wed May 7 2008 : Version 1.0.35
441  - During recovery, when we define the new set of lmasters (vnnmap)
442    only consider those nodes that have the can-be-lmaster capability
443    when we create the vnnmap. unless there are no nodes available which
444    supports this capability in which case we allow the recmaster to
445    become lmaster capable (temporarily).
446  - Extend the async framework so that we can use paralell async calls
447    to controls that return data.
448  - If we do not have the "can be recmaster" capability, make sure we will
449    lose any recmaster elections, unless there are no nodes available that
450    have the capability, in which case we "take/win" the election anyway.
451  - Close and reopen the reclock pnn file at regular intervals.
452    Make it a non-fatal event if we occasionally fail to open/read/write
453    to this file.
454  - Monitor that the recovery daemon is still running from the main ctdb
455    daemon and shutdown the main daemon when recovery daemon has terminated.
456  - Add a "ctdb getcapabilities" command to read the capabilities off a node.
457  - Define two new capabilities : can be recmaster and can be lmaster
458    and default both capabilities to YES.
459  - Log denied tcp connection attempts with DEBUG_ERR and not DEBUG_WARNING
460 * Thu Apr 24 2008 : Version 1.0.34
461  - When deleting a public ip from a node, try to migrate the ip to a different
462    node first.
463  - Change catdb to produce output similar to tdbdump
464  - When adding a new public ip address, if this ip does not exist yet in
465    the cluster, then grab the ip on the local node and activate it.
466  - When a node disagrees with the recmaster on WHO is the recmaster, then
467    mark that node as a recovery culprit so it will eventually become
468    banned.
469  - Make ctdb eventscript support the -n all argument.
470 * Thu Apr 10 2008 : Version 1.0.33
471  - Add facilities to include site local adaptations to the eventscript
472    by /etc/ctdb/rc.local which will be read by all eventscripts.
473  - Add a "ctdb version" command.
474  - Secure the domain socket with proper permissions from Chris Cowan
475  - Bugfixes for AIX from Chris Cowan
476 * Wed Apr 02 2008 : Version 1.0.32
477  - Add a control to have a node execute the eventscripts with arbitrary
478    command line arguments.
479  - Add a control "rddumpmemory" that will dump the talloc memory allocations
480    for the recovery daemon.
481  - Decorate the talloc memdump to produce better and easier memory leak
482    tracking. 
483  - Update the RHEL5 iscsi tgtd scripts to allow one iscsi target for each
484    public address.
485  - Add two new controls "addip/delip" that can be used to add/remove public
486    addresses to a node at runtime. After using these controls a "ctdb recover"
487    ir required to make the changes take.
488  - Fix a couple of slow memory leaks.
489 * Tue Mar 25 2008 : Version 1.0.31
490  - Add back controls to disable/enable monitoring on a node.
491  - Fix a memory leak where we used to attach CALL data to the ctdb structure
492    when performing a local call. Memory which would be lost if the call was
493    aborted.
494  - Reduce the loglevel for the log output when someone connects to a non
495    public ip address for samba.
496  - Redo and optimize the vacuuming process to send only one control to each
497    other node containing all records to be vacuumed instead of one
498    control per node per record.
499 * Tue Mar 04 2008 : Version 1.0.30
500  - Update documentation cor new commands and tuneables
501  - Add machinereadable output to the ip,uptime and getdebug commands
502  - Add a moveip command to manually failover/failback public ips
503  - Add NoIPFallback tuneable that prevents ip address failback
504  - Use file locking inside the CFS as alternative to verify when other nodes
505    Are connected/disconnected to be able to recover from split network
506  - Add DisableWhenUnhealthy tunable
507  - Add CTDB_START_AS_DISABLED sysconfig param
508  - Add --start-as-disabled flag to ctdb
509  - Add ability to monitor for OOM condition
510 * Thu Feb 21 2008 : Version 1.0.29
511  - Add a new command to make expansion of an existing cluster easier
512  - Fix bug with references to freed objects in the ctdb structure
513  - Propagate debuglevel changes to the recovery daemon
514  - Merge patches to event scripts from Mathieu Parent :
515  - MP: Simulate "service" on systems which do not provide this tool
516  - MP: Set correct permissions for events.d/README
517  - Add nice helper functions to start/stop nfs from the event scripts
518 * Fri Feb 08 2008 : Version 1.0.28
519  - Fix a problem where we tried to use ethtool on non-ethernet interfaces
520  - Warn if the ipvsadm packege is missing when LVS is used
521  - Dont use absolute pathnames in some of the event scripts
522  - Fix for persistent tdbs growing inifinitely.
523 * Wed Feb 06 2008 : Version 1.0.27
524  - Add eventscript for iscsi
525 * Thu Jan 31 2008 : Version 1.0.26
526  - Fix crashbug in tdb transaction code
527 * Tue Jan 29 2008 : Version 1.0.25
528  - added async recovery code
529  - make event scripts more portable
530  - fixed ctdb dumpmemory
531  - more efficient tdb allocation code
532  - improved machine readable ctdb status output
533  - added ctdb uptime
534 * Wed Jan 16 2008 : Version 1.0.24
535  - added syslog support
536  - documentation updates
537 * Wed Jan 16 2008 : Version 1.0.23
538  - fixed a memory leak in the recoveryd
539  - fixed a corruption bug in the new transaction code
540  - fixed a case where an packet for a disconnected client could be processed
541  - added http event script
542  - updated documentation
543 * Thu Jan 10 2008 : Version 1.0.22
544  - auto-run vacuum and repack ops
545 * Wed Jan 09 2008 : Version 1.0.21
546  - added ctdb vacuum and ctdb repack code
547 * Sun Jan 06 2008 : Version 1.0.20
548  - new transaction based recovery code
549 * Sat Jan 05 2008 : Version 1.0.19
550  - fixed non-master bug
551  - big speedup in recovery for large databases
552  - lots of changes to improve tdb and ctdb for high churn databases
553 * Thu Dec 27 2007 : Version 1.0.18
554  - fixed crash bug in monitor_handler
555 * Tue Dec 04 2007 : Version 1.0.17
556  - fixed bugs related to ban/unban of nodes
557  - fixed a race condition that could lead to monitoring being permanently disabled,
558    which would lead to long recovery times
559  - make deterministic IPs the default
560  - fixed a bug related to continuous recovery 
561  - added a debugging option --node-ip