Update to new release
[sahlberg/ctdb.git] / packaging / RPM / ctdb.spec
1 %define initdir %{_sysconfdir}/init.d
2
3 Summary: Clustered TDB
4 Vendor: Samba Team
5 Packager: Samba Team <samba@samba.org>
6 Name: ctdb
7 Version: 1.0
8 Release: 37
9 Epoch: 0
10 License: GNU GPL version 3
11 Group: System Environment/Daemons
12 URL: http://ctdb.samba.org/
13
14 Source: ctdb-%{version}.tar.gz
15
16 Prereq: /sbin/chkconfig /bin/mktemp /usr/bin/killall
17 Prereq: fileutils sed /etc/init.d
18
19 Provides: ctdb = %{version}
20
21 Prefix: /usr
22 BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24 %description
25 ctdb is the clustered database used by samba
26
27
28 #######################################################################
29
30 %prep
31 %setup -q
32 # setup the init script and sysconfig file
33 %setup -T -D -n ctdb-%{version} -q
34
35 %build
36
37 CC="gcc"
38
39 ## always run autogen.sh
40 ./autogen.sh
41
42 CFLAGS="$RPM_OPT_FLAGS $EXTRA -O0 -D_GNU_SOURCE -DCTDB_VERS=\"%{version}-%{release}\"" ./configure \
43         --prefix=%{_prefix} \
44         --sysconfdir=%{_sysconfdir} \
45         --mandir=%{_mandir} \
46         --localstatedir="/var"
47
48 make showflags
49 make   
50
51 %install
52 # Clean up in case there is trash left from a previous build
53 rm -rf $RPM_BUILD_ROOT
54
55 # Create the target build directory hierarchy
56 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
57 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
58
59 make DESTDIR=$RPM_BUILD_ROOT install
60
61 install -m644 config/ctdb.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ctdb
62 install -m755 config/ctdb.init $RPM_BUILD_ROOT%{initdir}/ctdb
63
64 # Remove "*.old" files
65 find $RPM_BUILD_ROOT -name "*.old" -exec rm -f {} \;
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 [ -x /sbin/chkconfig ] && /sbin/chkconfig --add ctdb
72
73 %preun
74 if [ $1 = 0 ] ; then
75     [ -x /sbin/chkconfig ] && /sbin/chkconfig --del ctdb
76 fi
77 exit 0
78
79 %postun
80 if [ "$1" -ge "1" ]; then
81         %{initdir}/ctdb restart >/dev/null 2>&1
82 fi      
83
84
85 #######################################################################
86 ## Files section                                                     ##
87 #######################################################################
88
89 %files
90 %defattr(-,root,root)
91
92 %config(noreplace) %{_sysconfdir}/sysconfig/ctdb
93 %attr(755,root,root) %config %{initdir}/ctdb
94
95 %{_sysconfdir}/ctdb/functions
96 %{_sysconfdir}/ctdb/events.d/README
97 %{_sysconfdir}/ctdb/events.d/00.ctdb
98 %{_sysconfdir}/ctdb/events.d/10.interface
99 %{_sysconfdir}/ctdb/events.d/40.vsftpd
100 %{_sysconfdir}/ctdb/events.d/41.httpd
101 %{_sysconfdir}/ctdb/events.d/50.samba
102 %{_sysconfdir}/ctdb/events.d/60.nfs
103 %{_sysconfdir}/ctdb/events.d/61.nfstickle
104 %{_sysconfdir}/ctdb/events.d/70.iscsi
105 %{_sysconfdir}/ctdb/events.d/90.ipmux
106 %{_sysconfdir}/ctdb/events.d/91.lvs
107 %{_sysconfdir}/ctdb/statd-callout
108 %{_sbindir}/ctdbd
109 %{_bindir}/ctdb
110 %{_bindir}/smnotify
111 %{_bindir}/ctdb_ipmux
112 %{_bindir}/ctdb_diagnostics
113 %{_bindir}/onnode.ssh
114 %{_bindir}/onnode.rsh
115 %{_bindir}/onnode
116 %{_mandir}/man1/ctdb.1.gz
117 %{_mandir}/man1/ctdbd.1.gz
118 %{_mandir}/man1/onnode.1.gz
119 %{_includedir}/ctdb.h
120 %{_includedir}/ctdb_private.h
121
122 %changelog
123 * Mon May 12 2008 : Version 1.0.37
124  - When we shutdown ctdb we close the transport down before we run the 
125    "shutdown" eventscripts. If ctdb decides to send a packet to a remote node
126    after we have shutdown the transport but before we have shutdown ctdbd
127    itself this could lead to a SEGV instead of a clean shutdown. Fix.
128  - When using the "exportfs" command to extract which NFS export directories
129    to monitor,  exportfs violates the "principle of least surprise" and
130    sometimes report a single export line as two lines of text output
131    causing the monitoring to fail.
132 * Fri May 9 2008 : Version 1.0.36
133  - fix a memory corruption bug that could cause the recovery daemon to crash.
134  - fix a bug with distributing public ip addresses during recovery.
135    If the node that is the recovery master did NOT use public addresses,
136    then it assumed that no other node in the cluster used them either and
137    thus skipped the entire step of reallocating public addresses.
138 * Wed May 7 2008 : Version 1.0.35
139  - During recovery, when we define the new set of lmasters (vnnmap)
140    only consider those nodes that have the can-be-lmaster capability
141    when we create the vnnmap. unless there are no nodes available which
142    supports this capability in which case we allow the recmaster to
143    become lmaster capable (temporarily).
144  - Extend the async framework so that we can use paralell async calls
145    to controls that return data.
146  - If we do not have the "can be recmaster" capability, make sure we will
147    lose any recmaster elections, unless there are no nodes available that
148    have the capability, in which case we "take/win" the election anyway.
149  - Close and reopen the reclock pnn file at regular intervals.
150    Make it a non-fatal event if we occasionally fail to open/read/write
151    to this file.
152  - Monitor that the recovery daemon is still running from the main ctdb
153    daemon and shutdown the main daemon when recovery daemon has terminated.
154  - Add a "ctdb getcapabilities" command to read the capabilities off a node.
155  - Define two new capabilities : can be recmaster and can be lmaster
156    and default both capabilities to YES.
157  - Log denied tcp connection attempts with DEBUG_ERR and not DEBUG_WARNING
158 * Thu Apr 24 2008 : Version 1.0.34
159  - When deleting a public ip from a node, try to migrate the ip to a different
160    node first.
161  - Change catdb to produce output similar to tdbdump
162  - When adding a new public ip address, if this ip does not exist yet in
163    the cluster, then grab the ip on the local node and activate it.
164  - When a node disagrees with the recmaster on WHO is the recmaster, then
165    mark that node as a recovery culprit so it will eventually become
166    banned.
167  - Make ctdb eventscript support the -n all argument.
168 * Thu Apr 10 2008 : Version 1.0.33
169  - Add facilities to include site local adaptations to the eventscript
170    by /etc/ctdb/rc.local which will be read by all eventscripts.
171  - Add a "ctdb version" command.
172  - Secure the domain socket with proper permissions from Chris Cowan
173  - Bugfixes for AIX from Chris Cowan
174 * Wed Apr 02 2008 : Version 1.0.32
175  - Add a control to have a node execute the eventscripts with arbitrary
176    command line arguments.
177  - Add a control "rddumpmemory" that will dump the talloc memory allocations
178    for the recovery daemon.
179  - Decorate the talloc memdump to produce better and easier memory leak
180    tracking. 
181  - Update the RHEL5 iscsi tgtd scripts to allow one iscsi target for each
182    public address.
183  - Add two new controls "addip/delip" that can be used to add/remove public
184    addresses to a node at runtime. After using these controls a "ctdb recover"
185    ir required to make the changes take.
186  - Fix a couple of slow memory leaks.
187 * Tue Mar 25 2008 : Version 1.0.31
188  - Add back controls to disable/enable monitoring on a node.
189  - Fix a memory leak where we used to attach CALL data to the ctdb structure
190    when performing a local call. Memory which would be lost if the call was
191    aborted.
192  - Reduce the loglevel for the log output when someone connects to a non
193    public ip address for samba.
194  - Redo and optimize the vacuuming process to send only one control to each
195    other node containing all records to be vacuumed instead of one
196    control per node per record.
197 * Tue Mar 04 2008 : Version 1.0.30
198  - Update documentation cor new commands and tuneables
199  - Add machinereadable output to the ip,uptime and getdebug commands
200  - Add a moveip command to manually failover/failback public ips
201  - Add NoIPFallback tuneable that prevents ip address failback
202  - Use file locking inside the CFS as alternative to verify when other nodes
203    Are connected/disconnected to be able to recover from split network
204  - Add DisableWhenUnhealthy tunable
205  - Add CTDB_START_AS_DISABLED sysconfig param
206  - Add --start-as-disabled flag to ctdb
207  - Add ability to monitor for OOM condition
208 * Thu Feb 21 2008 : Version 1.0.29
209  - Add a new command to make expansion of an existing cluster easier
210  - Fix bug with references to freed objects in the ctdb structure
211  - Propagate debuglevel changes to the recovery daemon
212  - Merge patches to event scripts from Mathieu Parent :
213  - MP: Simulate "service" on systems which do not provide this tool
214  - MP: Set correct permissions for events.d/README
215  - Add nice helper functions to start/stop nfs from the event scripts
216 * Fri Feb 08 2008 : Version 1.0.28
217  - Fix a problem where we tried to use ethtool on non-ethernet interfaces
218  - Warn if the ipvsadm packege is missing when LVS is used
219  - Dont use absolute pathnames in some of the event scripts
220  - Fix for persistent tdbs growing inifinitely.
221 * Wed Feb 06 2008 : Version 1.0.27
222  - Add eventscript for iscsi
223 * Thu Jan 31 2008 : Version 1.0.26
224  - Fix crashbug in tdb transaction code
225 * Tue Jan 29 2008 : Version 1.0.25
226  - added async recovery code
227  - make event scripts more portable
228  - fixed ctdb dumpmemory
229  - more efficient tdb allocation code
230  - improved machine readable ctdb status output
231  - added ctdb uptime
232 * Wed Jan 16 2008 : Version 1.0.24
233  - added syslog support
234  - documentation updates
235 * Wed Jan 16 2008 : Version 1.0.23
236  - fixed a memory leak in the recoveryd
237  - fixed a corruption bug in the new transaction code
238  - fixed a case where an packet for a disconnected client could be processed
239  - added http event script
240  - updated documentation
241 * Thu Jan 10 2008 : Version 1.0.22
242  - auto-run vacuum and repack ops
243 * Wed Jan 09 2008 : Version 1.0.21
244  - added ctdb vacuum and ctdb repack code
245 * Sun Jan 06 2008 : Version 1.0.20
246  - new transaction based recovery code
247 * Sat Jan 05 2008 : Version 1.0.19
248  - fixed non-master bug
249  - big speedup in recovery for large databases
250  - lots of changes to improve tdb and ctdb for high churn databases
251 * Thu Dec 27 2007 : Version 1.0.18
252  - fixed crash bug in monitor_handler
253 * Tue Dec 04 2007 : Version 1.0.17
254  - fixed bugs related to ban/unban of nodes
255  - fixed a race condition that could lead to monitoring being permanently disabled,
256    which would lead to long recovery times
257  - make deterministic IPs the default
258  - fixed a bug related to continuous recovery 
259  - added a debugging option --node-ip