update to .41
[sahlberg/ctdb.git] / packaging / RPM / ctdb.spec
1 %define initdir %{_sysconfdir}/init.d
2
3 Summary: Clustered TDB
4 Vendor: Samba Team
5 Packager: Samba Team <samba@samba.org>
6 Name: ctdb
7 Version: 1.0
8 Release: 41
9 Epoch: 0
10 License: GNU GPL version 3
11 Group: System Environment/Daemons
12 URL: http://ctdb.samba.org/
13
14 Source: ctdb-%{version}.tar.gz
15
16 Prereq: /sbin/chkconfig /bin/mktemp /usr/bin/killall
17 Prereq: fileutils sed /etc/init.d
18
19 Provides: ctdb = %{version}
20
21 Prefix: /usr
22 BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24 %description
25 ctdb is the clustered database used by samba
26
27
28 #######################################################################
29
30 %prep
31 %setup -q
32 # setup the init script and sysconfig file
33 %setup -T -D -n ctdb-%{version} -q
34
35 %build
36
37 CC="gcc"
38
39 ## always run autogen.sh
40 ./autogen.sh
41
42 CFLAGS="$RPM_OPT_FLAGS $EXTRA -O0 -D_GNU_SOURCE -DCTDB_VERS=\"%{version}-%{release}\"" ./configure \
43         --prefix=%{_prefix} \
44         --sysconfdir=%{_sysconfdir} \
45         --mandir=%{_mandir} \
46         --localstatedir="/var"
47
48 make showflags
49 make   
50
51 %install
52 # Clean up in case there is trash left from a previous build
53 rm -rf $RPM_BUILD_ROOT
54
55 # Create the target build directory hierarchy
56 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
57 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
58
59 make DESTDIR=$RPM_BUILD_ROOT install
60
61 install -m644 config/ctdb.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ctdb
62 install -m755 config/ctdb.init $RPM_BUILD_ROOT%{initdir}/ctdb
63
64 # Remove "*.old" files
65 find $RPM_BUILD_ROOT -name "*.old" -exec rm -f {} \;
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 [ -x /sbin/chkconfig ] && /sbin/chkconfig --add ctdb
72
73 %preun
74 if [ $1 = 0 ] ; then
75     [ -x /sbin/chkconfig ] && /sbin/chkconfig --del ctdb
76 fi
77 exit 0
78
79 %postun
80 if [ "$1" -ge "1" ]; then
81         %{initdir}/ctdb restart >/dev/null 2>&1
82 fi      
83
84
85 #######################################################################
86 ## Files section                                                     ##
87 #######################################################################
88
89 %files
90 %defattr(-,root,root)
91
92 %config(noreplace) %{_sysconfdir}/sysconfig/ctdb
93 %attr(755,root,root) %config %{initdir}/ctdb
94
95 %{_sysconfdir}/ctdb/functions
96 %{_sysconfdir}/ctdb/events.d/README
97 %{_sysconfdir}/ctdb/events.d/00.ctdb
98 %{_sysconfdir}/ctdb/events.d/10.interface
99 %{_sysconfdir}/ctdb/events.d/40.vsftpd
100 %{_sysconfdir}/ctdb/events.d/41.httpd
101 %{_sysconfdir}/ctdb/events.d/50.samba
102 %{_sysconfdir}/ctdb/events.d/60.nfs
103 %{_sysconfdir}/ctdb/events.d/61.nfstickle
104 %{_sysconfdir}/ctdb/events.d/70.iscsi
105 %{_sysconfdir}/ctdb/events.d/90.ipmux
106 %{_sysconfdir}/ctdb/events.d/91.lvs
107 %{_sysconfdir}/ctdb/statd-callout
108 %{_sbindir}/ctdbd
109 %{_bindir}/ctdb
110 %{_bindir}/smnotify
111 %{_bindir}/ctdb_ipmux
112 %{_bindir}/ctdb_diagnostics
113 %{_bindir}/onnode.ssh
114 %{_bindir}/onnode.rsh
115 %{_bindir}/onnode
116 %{_mandir}/man1/ctdb.1.gz
117 %{_mandir}/man1/ctdbd.1.gz
118 %{_mandir}/man1/onnode.1.gz
119 %{_includedir}/ctdb.h
120 %{_includedir}/ctdb_private.h
121
122 %changelog
123 * Wed May 28 2008 : Version 1.0.41
124  - Reactivate the safe writes to persistent databases and solve the
125    locking issues. Locking issues are solved the only possible way,
126    by using a child process to do the writes.  Expensive and slow but... . 
127 * Tue May 27 2008 : Version 1.0.40
128  - Read the samba sysconfig file from the 50.samba eventscript
129  - Fix some emmory hierarchical bugs in the persistent write handling
130 * Thu May 22 2008 : Version 1.0.39
131  - Moved a CTDB_MANAGES_NFS, CTDB_MANAGES_ISCSI and CTDB_MANAGES_CSFTPD
132    into /etc/sysconfig/ctdb
133  - Lowered some debug messages to not fill the logfile with entries
134    that normally occur in the default configuration.
135 * Fri May 16 2008 : Version 1.0.38
136  - Add machine readable output support to "ctdb getmonmode"
137  - Lots of tweaks and enhancements if the event scripts are "slow"
138  - Merge from tridge: an attempt to break the chicken-and-egg deadlock that
139    net conf introduces if used from an eventscript.
140  - Enhance tickles so we can tickle an ipv6 connection.
141  - Start adding ipv6 support : create a new container to replace sockaddr_in.
142  - Add a checksum routine for ipv6/tcp
143  - When starting up ctdb, let the init script do a tdbdump on all
144    persistent databases and verify that they are good (i.e. not corrupted).
145  - Try to use "safe transactions" when writing to a persistent database
146    that was opened with the TDB_NOSYNC flag. If we can get the transaction
147    thats great, if we cant  we have to write anyway since we cant block here.
148 * Mon May 12 2008 : Version 1.0.37
149  - When we shutdown ctdb we close the transport down before we run the 
150    "shutdown" eventscripts. If ctdb decides to send a packet to a remote node
151    after we have shutdown the transport but before we have shutdown ctdbd
152    itself this could lead to a SEGV instead of a clean shutdown. Fix.
153  - When using the "exportfs" command to extract which NFS export directories
154    to monitor,  exportfs violates the "principle of least surprise" and
155    sometimes report a single export line as two lines of text output
156    causing the monitoring to fail.
157 * Fri May 9 2008 : Version 1.0.36
158  - fix a memory corruption bug that could cause the recovery daemon to crash.
159  - fix a bug with distributing public ip addresses during recovery.
160    If the node that is the recovery master did NOT use public addresses,
161    then it assumed that no other node in the cluster used them either and
162    thus skipped the entire step of reallocating public addresses.
163 * Wed May 7 2008 : Version 1.0.35
164  - During recovery, when we define the new set of lmasters (vnnmap)
165    only consider those nodes that have the can-be-lmaster capability
166    when we create the vnnmap. unless there are no nodes available which
167    supports this capability in which case we allow the recmaster to
168    become lmaster capable (temporarily).
169  - Extend the async framework so that we can use paralell async calls
170    to controls that return data.
171  - If we do not have the "can be recmaster" capability, make sure we will
172    lose any recmaster elections, unless there are no nodes available that
173    have the capability, in which case we "take/win" the election anyway.
174  - Close and reopen the reclock pnn file at regular intervals.
175    Make it a non-fatal event if we occasionally fail to open/read/write
176    to this file.
177  - Monitor that the recovery daemon is still running from the main ctdb
178    daemon and shutdown the main daemon when recovery daemon has terminated.
179  - Add a "ctdb getcapabilities" command to read the capabilities off a node.
180  - Define two new capabilities : can be recmaster and can be lmaster
181    and default both capabilities to YES.
182  - Log denied tcp connection attempts with DEBUG_ERR and not DEBUG_WARNING
183 * Thu Apr 24 2008 : Version 1.0.34
184  - When deleting a public ip from a node, try to migrate the ip to a different
185    node first.
186  - Change catdb to produce output similar to tdbdump
187  - When adding a new public ip address, if this ip does not exist yet in
188    the cluster, then grab the ip on the local node and activate it.
189  - When a node disagrees with the recmaster on WHO is the recmaster, then
190    mark that node as a recovery culprit so it will eventually become
191    banned.
192  - Make ctdb eventscript support the -n all argument.
193 * Thu Apr 10 2008 : Version 1.0.33
194  - Add facilities to include site local adaptations to the eventscript
195    by /etc/ctdb/rc.local which will be read by all eventscripts.
196  - Add a "ctdb version" command.
197  - Secure the domain socket with proper permissions from Chris Cowan
198  - Bugfixes for AIX from Chris Cowan
199 * Wed Apr 02 2008 : Version 1.0.32
200  - Add a control to have a node execute the eventscripts with arbitrary
201    command line arguments.
202  - Add a control "rddumpmemory" that will dump the talloc memory allocations
203    for the recovery daemon.
204  - Decorate the talloc memdump to produce better and easier memory leak
205    tracking. 
206  - Update the RHEL5 iscsi tgtd scripts to allow one iscsi target for each
207    public address.
208  - Add two new controls "addip/delip" that can be used to add/remove public
209    addresses to a node at runtime. After using these controls a "ctdb recover"
210    ir required to make the changes take.
211  - Fix a couple of slow memory leaks.
212 * Tue Mar 25 2008 : Version 1.0.31
213  - Add back controls to disable/enable monitoring on a node.
214  - Fix a memory leak where we used to attach CALL data to the ctdb structure
215    when performing a local call. Memory which would be lost if the call was
216    aborted.
217  - Reduce the loglevel for the log output when someone connects to a non
218    public ip address for samba.
219  - Redo and optimize the vacuuming process to send only one control to each
220    other node containing all records to be vacuumed instead of one
221    control per node per record.
222 * Tue Mar 04 2008 : Version 1.0.30
223  - Update documentation cor new commands and tuneables
224  - Add machinereadable output to the ip,uptime and getdebug commands
225  - Add a moveip command to manually failover/failback public ips
226  - Add NoIPFallback tuneable that prevents ip address failback
227  - Use file locking inside the CFS as alternative to verify when other nodes
228    Are connected/disconnected to be able to recover from split network
229  - Add DisableWhenUnhealthy tunable
230  - Add CTDB_START_AS_DISABLED sysconfig param
231  - Add --start-as-disabled flag to ctdb
232  - Add ability to monitor for OOM condition
233 * Thu Feb 21 2008 : Version 1.0.29
234  - Add a new command to make expansion of an existing cluster easier
235  - Fix bug with references to freed objects in the ctdb structure
236  - Propagate debuglevel changes to the recovery daemon
237  - Merge patches to event scripts from Mathieu Parent :
238  - MP: Simulate "service" on systems which do not provide this tool
239  - MP: Set correct permissions for events.d/README
240  - Add nice helper functions to start/stop nfs from the event scripts
241 * Fri Feb 08 2008 : Version 1.0.28
242  - Fix a problem where we tried to use ethtool on non-ethernet interfaces
243  - Warn if the ipvsadm packege is missing when LVS is used
244  - Dont use absolute pathnames in some of the event scripts
245  - Fix for persistent tdbs growing inifinitely.
246 * Wed Feb 06 2008 : Version 1.0.27
247  - Add eventscript for iscsi
248 * Thu Jan 31 2008 : Version 1.0.26
249  - Fix crashbug in tdb transaction code
250 * Tue Jan 29 2008 : Version 1.0.25
251  - added async recovery code
252  - make event scripts more portable
253  - fixed ctdb dumpmemory
254  - more efficient tdb allocation code
255  - improved machine readable ctdb status output
256  - added ctdb uptime
257 * Wed Jan 16 2008 : Version 1.0.24
258  - added syslog support
259  - documentation updates
260 * Wed Jan 16 2008 : Version 1.0.23
261  - fixed a memory leak in the recoveryd
262  - fixed a corruption bug in the new transaction code
263  - fixed a case where an packet for a disconnected client could be processed
264  - added http event script
265  - updated documentation
266 * Thu Jan 10 2008 : Version 1.0.22
267  - auto-run vacuum and repack ops
268 * Wed Jan 09 2008 : Version 1.0.21
269  - added ctdb vacuum and ctdb repack code
270 * Sun Jan 06 2008 : Version 1.0.20
271  - new transaction based recovery code
272 * Sat Jan 05 2008 : Version 1.0.19
273  - fixed non-master bug
274  - big speedup in recovery for large databases
275  - lots of changes to improve tdb and ctdb for high churn databases
276 * Thu Dec 27 2007 : Version 1.0.18
277  - fixed crash bug in monitor_handler
278 * Tue Dec 04 2007 : Version 1.0.17
279  - fixed bugs related to ban/unban of nodes
280  - fixed a race condition that could lead to monitoring being permanently disabled,
281    which would lead to long recovery times
282  - make deterministic IPs the default
283  - fixed a bug related to continuous recovery 
284  - added a debugging option --node-ip