Simplify handling of plugin installation.
[jelmer/samba4-debian.git] / source / Makefile
index a99dc825f17a5a466b4dc2627364b1293a9744a4..e5399e4c3213f9d2a13100a58b9b03b12fd71f12 100644 (file)
@@ -122,6 +122,8 @@ installbin:: $(SBIN_PROGS) $(BIN_PROGS) $(TORTURE_PROGS) installdirs
                $(DESTDIR)$(TORTUREDIR) \
                $(TORTURE_PROGS)
 
+installplugins::
+
 installlib:: $(INSTALLABLE_SHARED_LIBS) $(STATIC_LIBS) installdirs
        @$(SHELL) $(srcdir)/script/installlib.sh $(DESTDIR)$(libdir) "$(SHLIBEXT)" $(INSTALLABLE_SHARED_LIBS) 
        #@$(SHELL) $(srcdir)/script/installlib.sh $(DESTDIR)$(libdir) "$(STLIBEXT)" $(STATIC_LIBS)
@@ -165,6 +167,8 @@ uninstallheader::
 uninstallman::
        @$(SHELL) $(srcdir)/script/uninstallman.sh $(DESTDIR)$(mandir) $(MANPAGES)
 
+uninstallplugins::
+
 config.status:
        @echo "config.status does not exist. Please run ./configure."
        @/bin/false