build/autoconf: put ld check variable in quotes
[amitay/samba.git] / source3 / configure.in
index 56c91903cb9bac2ad85de7a94c2b22c8fe115b7d..552535bfafec313eab5959eca41714cd0c60e1b5 100644 (file)
@@ -229,7 +229,7 @@ dnl warnings when building modules.
 if test "$ac_cv_prog_gnu_ld" = "yes"; then
        ac_cv_gnu_ld_version=`$CC -Wl,-v /dev/null 2> /dev/null < /dev/null | grep "GNU ld"`
        # we need to make a 2nd (separate!) check on the output of stderr, see bug #7825:
-       if test -z ${ac_cv_gnu_ld_version} ; then
+       if test -z "$ac_cv_gnu_ld_version" ; then
          ac_cv_gnu_ld_version=`$CC -Wl,-v /dev/null 2>&1 > /dev/null < /dev/null | grep "GNU ld"`
        fi
        AC_MSG_CHECKING(GNU ld release date)